dev-perl/REST-Client: Add build fix for Perl 5.26, bug 623094
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 21:21:52 +0000 (23:21 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Mon, 3 Jul 2017 21:21:52 +0000 (23:21 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-perl/REST-Client/REST-Client-273.ebuild

index 5eafd53602d1c9e97f1e68976db8a129382a7224..b23a0024acabb46822dac2e5b29d70ecc6d8e3ae 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -21,3 +21,9 @@ DEPEND="${RDEPEND}
        virtual/perl-ExtUtils-MakeMaker
        test? ( virtual/perl-Test-Simple )
 "
+
+src_prepare() {
+       sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+               die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+       perl-module_src_prepare
+}