dev-python/cherrypy: Fix sed to remove pytest-cov
authorPatrick McLean <patrick.mclean@sony.com>
Mon, 30 Mar 2020 22:06:28 +0000 (15:06 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Mon, 30 Mar 2020 22:06:42 +0000 (15:06 -0700)
We need to make sure all pytest-cov related parameters are stripped,
not just the first one.

Bug: https://bugs.gentoo.org/715008
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/cherrypy/cherrypy-18.5.0.ebuild

index d113700efc16d869a069df3c1afe1cea335ecb64..2e86a61b646233c85b299900bca5dc2378c8dba2 100644 (file)
@@ -53,9 +53,9 @@ python_prepare_all() {
        sed -r -e '/(pytest-sugar|pytest-cov)/ d' \
                -i setup.py || die
 
-       sed -r -e 's:--cov-report[[:space:]]+[[:graph:]]+::' \
-               -e 's:--cov[[:graph:]]+::' \
-               -e 's:--doctest[[:graph:]]+::' \
+       sed -r -e 's:--cov-report[[:space:]]+[[:graph:]]+::g' \
+               -e 's:--cov[[:graph:]]+::g' \
+               -e 's:--doctest[[:graph:]]+::g' \
                -i pytest.ini || die
 
        distutils-r1_python_prepare_all