app-accessibility/at-spi2-atk: Version bump to 2.30.0
authorMatt Turner <mattst88@gentoo.org>
Thu, 7 Feb 2019 07:39:12 +0000 (23:39 -0800)
committerMart Raudsepp <leio@gentoo.org>
Mon, 18 Feb 2019 18:57:38 +0000 (20:57 +0200)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-accessibility/at-spi2-atk/Manifest
app-accessibility/at-spi2-atk/at-spi2-atk-2.30.0.ebuild [new file with mode: 0644]

index 96aceac6124a85bbc11ef056f40e9f9893721424..18e357fbb49b5e55c8107252a22d2d6171c879ad 100644 (file)
@@ -1,2 +1,3 @@
 DIST at-spi2-atk-2.24.1.tar.xz 308576 BLAKE2B 92b96c54cd5a2dbd8a3dddbaa3188b3396ef8e4631cc9438e4ba57da27672d509babae3415c66d2c6afc74855ff0536d4cc6f24a8cecf66478021d350b3572a1 SHA512 5dbc186c7ea4f7f34aa0acaf90f683e549162caa274ba5b5818ae9992b52f1b475923d9818870978e87e3dacdf1018db31810d2d53b39bb4f068bcb64a423f23
 DIST at-spi2-atk-2.26.2.tar.xz 322800 BLAKE2B 108a01fd8c16816d9953ad42721080dd6dcb9f75c95c412387d7f54920998c66eb5855eb859e8e00096a47b387d05779691887a7717d31f4c70681d69a9c8266 SHA512 f938b8e2b999fcdfa13e9433bd13c39430bae2ceae0c664a24caccc6af522947bf73de02de3c359807f5370a85961193df2ba24b193b60b915c61828ea747bb2
+DIST at-spi2-atk-2.30.0.tar.xz 94824 BLAKE2B 65f8abb034a610e8aaa72c4d0e3c93fa03f6737cbf8bff28c885c654ba3fe98e8750e6398326e47069f12d33f75eae729cbafdfca31a3a0ab7b233ba3f8a4c58 SHA512 d7a02c347e31d78da81455cff77b44ab6d9e11add8d9457fba6a6b354cef731ab73e8a83060c150f3ef3d5191bfbc649618360a61c9826816b1aafb3e2bea7d5
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.30.0.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.30.0.ebuild
new file mode 100644 (file)
index 0000000..67f644b
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org meson multilib-minimal virtualx
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+       >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+       >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+       >=dev-libs/atk-2.30.0[${MULTILIB_USEDEP}]
+       >=app-accessibility/at-spi2-core-2.30.0[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+multilib_src_configure() {
+       local emesonargs=(
+               -Ddisable_p2p=$(usex test false true)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       virtx dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+multilib_src_install() {
+       meson_src_install
+}