Combine the two 'file.executable' checks into a single one.
authorMichał Górny <gentoo@mgorny.alt.pl>
Wed, 14 Jul 2010 21:17:07 +0000 (23:17 +0200)
committerZac Medico <zmedico@gentoo.org>
Thu, 15 Jul 2010 02:34:58 +0000 (19:34 -0700)
Instead of performing a single 'file.executable' check on auxiliary
files and then another one on ebuild files, use a single check for them.
This unifies the path output too.

bin/repoman

index 8834b642bd7b4db21fe565b0f2f3476f48fb0d29..0a1a92dd86148551074813a7523591894d564fc3 100755 (executable)
@@ -1078,7 +1078,7 @@ for x in scanlist:
        ebuildlist=[]
        pkgs = {}
        for y in checkdirlist:
-               if y in no_exec and \
+               if (y in no_exec or y.endswith(".ebuild")) and \
                        stat.S_IMODE(os.stat(os.path.join(checkdir, y)).st_mode) & 0o111:
                                stats["file.executable"] += 1
                                fails["file.executable"].append(os.path.join(checkdir, y))
@@ -1394,9 +1394,6 @@ for x in scanlist:
                        stats['changelog.ebuildadded'] += 1
                        fails['changelog.ebuildadded'].append(relative_path)
 
-               if stat.S_IMODE(os.stat(full_path).st_mode) & 0o111:
-                       stats["file.executable"] += 1
-                       fails["file.executable"].append(x+"/"+y+".ebuild")
                if vcs in ("cvs", "svn", "bzr") and check_ebuild_notadded and y not in eadded:
                        #ebuild not added to vcs
                        stats["ebuild.notadded"]=stats["ebuild.notadded"]+1