www-apps/otrs: bump to -4.0.13 from bug #562242
authorIan Delaney <idella4@gentoo.org>
Mon, 5 Oct 2015 08:13:04 +0000 (16:13 +0800)
committerIan Delaney <idella4@gentoo.org>
Mon, 5 Oct 2015 08:13:04 +0000 (16:13 +0800)
Package-Manager: portage-2.2.20.1

www-apps/otrs/Manifest
www-apps/otrs/otrs-4.0.13.ebuild [new file with mode: 0644]

index e4798bd407d778c3f15045ea6c18838137fc6608..70bc366a4fa88e3f80c71bc66da4ab2db7811f49 100644 (file)
@@ -1 +1,2 @@
 DIST otrs-4.0.12.tar.bz2 14373765 SHA256 ea0a7b2019c46108f78d2329aa40ec5024405f08b586b6b33a6fca6a31ca9880 SHA512 17177b42c3768d271388fbe7abef033553fa524ba819a903b3f151b560de31183c5a1d975f8eb75f755b8bbf99331808309002f38cf3f469b22eadc8fefaa911 WHIRLPOOL 07b3d81c36e10f89ba1498c8d80845f53fc44feab25903addb8c3e6fa567633ec9938115859b5b81bc74efaa7c65286a1f501d6472737e00c47cfa48b77b2ac4
+DIST otrs-4.0.13.tar.bz2 14376200 SHA256 1c663c264043b65369f5608f9c5fcfc90938147053b14581db306df0c5e3e9ff SHA512 fb6156385643c838f46f80eeb8db2777ed426bca10df0ea94654df80b84e6dfd320a1ef6e43312edfcdb1a735e592cc49707a9507a47f2a5e3f5c80d9e0ccdc4 WHIRLPOOL ff8654485bf69ea08abd97e08dcaf68633f16242afc9beb169b0682a2155e4e4e89f5776d36eaaf15ab2ecde0717fb9c85676a3120ee01a21d3c70068605d669
diff --git a/www-apps/otrs/otrs-4.0.13.ebuild b/www-apps/otrs/otrs-4.0.13.ebuild
new file mode 100644 (file)
index 0000000..ff592b2
--- /dev/null
@@ -0,0 +1,131 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils confutils user
+
+DESCRIPTION="OTRS is an Open source Ticket Request System"
+HOMEPAGE="http://otrs.org/"
+SRC_URI="http://ftp.otrs.org/pub/${PN}/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="apache2 fastcgi +gd ldap mod_perl +mysql pdf postgres soap"
+SLOT="0"
+
+DEPEND="media-libs/libpng"
+
+RDEPEND="dev-perl/Apache-Reload
+               dev-perl/Archive-Zip
+               dev-perl/DBI
+               dev-perl/IO-Socket-SSL
+               dev-perl/JSON-XS
+               dev-perl/LWP-UserAgent-Determined
+               dev-perl/Mail-POP3Client
+               dev-perl/Mail-IMAPClient
+               >dev-perl/Net-DNS-0.60
+               dev-perl/Template-Toolkit
+               dev-perl/Text-CSV_XS
+               dev-perl/TimeDate
+               dev-perl/XML-Parser
+               dev-perl/YAML-LibYAML
+       apache2? ( mod_perl? ( www-servers/apache:2
+               =www-apache/libapreq2-2* www-apache/mod_perl )
+               !fastcgi? ( !mod_perl? ( www-servers/apache:2[suexec] ) ) )
+       fastcgi? ( dev-perl/FCGI virtual/httpd-fastcgi )
+       !fastcgi? ( !apache2? ( virtual/httpd-cgi ) )
+       gd? ( dev-perl/GD
+               dev-perl/GDTextUtil
+               dev-perl/GDGraph )
+       ldap? ( dev-perl/perl-ldap )
+       mysql? ( dev-perl/DBD-mysql )
+       postgres? ( dev-perl/DBD-Pg )
+       pdf? ( >=dev-perl/PDF-API2-0.73
+               virtual/perl-Compress-Raw-Zlib )
+       soap? (
+               dev-perl/SOAP-Lite
+               !=dev-perl/SOAP-Lite-0.711
+               !=dev-perl/SOAP-Lite-0.712 )
+       "
+
+OTRS_HOME="/var/lib/otrs"
+
+pkg_setup() {
+       # The enewuser otrs will fail if apache isn't there, but it's an optional dep
+       # so we create the apache user here just in case
+       enewgroup apache 81
+       enewuser apache 81 -1 /var/www apache
+       enewuser otrs -1 -1 ${OTRS_HOME} apache
+       confutils_require_any mysql postgres
+}
+
+src_prepare() {
+       rm -fr "${S}/scripts"/{auto_*,redhat*,suse*,*.spec} || die
+       cp Kernel/Config.pm{.dist,} || die
+
+       # Fix broken png files
+       pngfix -q --out=out.png "${S}/var/httpd/htdocs/skins/Agent/default/img/otrs-verify.png"
+       mv -f out.png "${S}/var/httpd/htdocs/skins/Agent/default/img/otrs-verify.png" || die
+
+       sed -i -e "s:/opt/otrs:${OTRS_HOME}:g" "${S}"/Kernel/Config.pm \
+               || die "sed failed"
+
+       grep -lR "/opt" "${S}"/scripts | \
+               xargs sed -i -e "s:/opt/otrs:${OTRS_HOME}:g" \
+               || die "sed failed"
+
+       cd Kernel/Config/ || die
+       for i in *.dist; do
+               cp ${i} $(basename ${i} .dist) || die
+       done
+
+       echo "CONFIG_PROTECT=\"${OTRS_HOME}/Kernel/Config.pm \
+               ${OTRS_HOME}/Kernel/Config/GenericAgent.pm\"" > "${T}/50${PN}"
+}
+
+# This is too automagic, either einfo telling user or installing to /etc/cron.d/ should be preferred
+pkg_config() {
+       einfo "Installing cronjobs"
+       crontab -u otrs /usr/share/doc/${PF}/crontab
+}
+
+src_install() {
+       dodoc CHANGES.md README*
+
+       insinto "${OTRS_HOME}"
+       doins -r .fetchmailrc.dist .mailfilter.dist .procmailrc.dist RELEASE \
+               Custom Kernel bin scripts var
+
+       cat "${S}"/var/cron/*.dist > crontab
+       insinto /usr/share/doc/${PF}/
+       doins crontab
+
+       for a in article log pics/images pics/stats pics sessions spool tmp tmp/CacheFileStorable
+       do
+               keepdir "${OTRS_HOME}/var/${a}"
+       done
+       doenvd "${T}/50${PN}"
+}
+
+pkg_postinst() {
+       einfo "Setting correct permissions ..."
+       /usr/bin/env perl "${OTRS_HOME}"/bin/otrs.SetPermissions.pl "${OTRS_HOME}" \
+               --otrs-user=otrs \
+               --web-group=apache \
+               || die "Could not set permissions"
+
+       einfo "Rebuilding config ..."
+       /usr/bin/env perl "${OTRS_HOME}"/bin/otrs.RebuildConfig.pl \
+               || die "Could not rebuild config"
+
+       einfo "Deleting cache ..."
+       /usr/bin/env perl "${OTRS_HOME}"/bin/otrs.DeleteCache.pl \
+               || die "Could not delete cache"
+
+       einfo "Installation done!"
+
+       elog "Enable cronjobs with the following command:"
+       elog "crontab -u otrs crontab"
+}