www-servers/tornado: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:33:12 +0000 (14:33 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 12:33:12 +0000 (14:33 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-servers/tornado/tornado-6.0.3-r1.ebuild [deleted file]

diff --git a/www-servers/tornado/tornado-6.0.3-r1.ebuild b/www-servers/tornado/tornado-6.0.3-r1.ebuild
deleted file mode 100644 (file)
index 971f3a1..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python web framework and asynchronous networking library"
-HOMEPAGE="https://www.tornadoweb.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
-       >=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
-       >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${CDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="${CDEPEND}"
-
-distutils_enable_sphinx docs \
-       dev-python/sphinx_rtd_theme \
-       dev-python/sphinxcontrib-asyncio
-
-# doc without intersphinx does not build (asyncio error)
-#PATCHES=(
-#      "${FILESDIR}"/4.5.1-drop-intersphinx.patch
-#)
-
-python_test() {
-       local -x ASYNC_TEST_TIMEOUT=60
-       "${PYTHON}" -m tornado.test.runtests --verbose ||
-               die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       if use examples; then
-               insinto /usr/share/doc/${PF}/examples
-               doins -r demos/.
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-       distutils-r1_python_install_all
-}