dev-lisp/clx: Syncs with Lisp overlay
authorChema Alonso Josa <nimiux@gentoo.org>
Wed, 5 Apr 2017 15:16:24 +0000 (17:16 +0200)
committerChema Alonso Josa <nimiux@gentoo.org>
Wed, 5 Apr 2017 15:16:45 +0000 (17:16 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-lisp/clx/clx-0.7.4-r1.ebuild [moved from dev-lisp/clx/clx-0.7.4.ebuild with 74% similarity]
dev-lisp/clx/clx-9999.ebuild
dev-lisp/clx/metadata.xml

similarity index 74%
rename from dev-lisp/clx/clx-0.7.4.ebuild
rename to dev-lisp/clx/clx-0.7.4-r1.ebuild
index 3010ba4bf047f4978c2305d353465c498a1fc444..e229aaf004b91e1e04b05c9b49989c69983438b8 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
 inherit common-lisp-3 eutils
 
@@ -20,11 +20,12 @@ RDEPEND="!dev-lisp/cl-${PN}"
 
 src_prepare() {
        rm -v {exclcmac,sockcl,defsystem,provide,cmudep}.lisp || die
-       epatch "${FILESDIR}"/gentoo-fix-asd.patch
-       epatch "${FILESDIR}"/gentoo-fix-dep-openmcl.patch
-       epatch "${FILESDIR}"/gentoo-fix-unused-vars.patch
-       epatch "${FILESDIR}"/gentoo-fix-obsolete-eval-when.patch
-       epatch "${FILESDIR}"/gentoo-fix-dynamic-extent-sbcl-1.0.45.patch
+       eapply "${FILESDIR}"/gentoo-fix-asd.patch
+       eapply "${FILESDIR}"/gentoo-fix-dep-openmcl.patch
+       eapply "${FILESDIR}"/gentoo-fix-unused-vars.patch
+       eapply "${FILESDIR}"/gentoo-fix-obsolete-eval-when.patch
+       eapply "${FILESDIR}"/gentoo-fix-dynamic-extent-sbcl-1.0.45.patch
+       eapply_user
 }
 
 src_compile() {
index 000f4485817ba625327aa96a80198758b8b19721..efbfcfbe73782502f7e049c228036c7e6176b6eb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
index 6d2b54b52c96a89e70881941f6f12b0efc95b6ce..47c41000f413ca72db6b8091c922adfb9b69225c 100644 (file)
@@ -1,10 +1,9 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <maintainer type="person">
-               <email>nimiux@gentoo.org</email>
-               <name>Chema Alonso</name>
-               <description>Maintainer</description>
+       <maintainer type="project">
+               <email>common-lisp@gentoo.org</email>
+               <name>Gentoo Common Lisp Project</name>
        </maintainer>
        <longdescription lang="en">
                CLX provides an implementation of the X Window System protocol to