app-text/cmark: version bump to 0.28.3.
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>
Thu, 30 Nov 2017 05:35:52 +0000 (10:35 +0500)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 1 Dec 2017 21:23:10 +0000 (22:23 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-text/cmark/Manifest
app-text/cmark/cmark-0.28.3.ebuild [new file with mode: 0644]

index 4a838e6d2471ad4bc3cc87fd8d50be53c481e74d..975326d4c52a484afc5699eb22ff522977bba0a9 100644 (file)
@@ -1 +1,2 @@
 DIST cmark-0.28.0.tar.gz 228973 BLAKE2B e0f42a7a5929eb8fb7a2fb9405372d626b2fea5f895b9320a28629022a8280d01af67e8e13101565ce86a2dbc4b8191eb461e70e45e7fa33c72b8e8266c2ee78 SHA512 86aeb42f17440c8e743057851bc3cee9ed4b3fa27dacc37d6af54dee7739210a712020e59c102ed1852b7c3f904881cb4e9b80ea475772095514c4025284cbb6
+DIST cmark-0.28.3.tar.gz 229391 BLAKE2B b235d3dd8ed9b83d8fd6ec495d311bed854ad61d28e5a5087f40f7e512977892fcdff7c51e8683db87e0ee8e5e73338fe11b8829e70c6f07c59e917a8b7268cc SHA512 409105a3228a8ae22ba6acf95cd99bc9a2c20f8603aa0e803a33172eb6ef53f80f8f0262d2258b77f9fd6e1f2e9017a6c906b88f761e053c09ef88c9ffab7d29
diff --git a/app-text/cmark/cmark-0.28.3.ebuild b/app-text/cmark/cmark-0.28.3.ebuild
new file mode 100644 (file)
index 0000000..55850c4
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+       use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DCMARK_LIB_FUZZER=OFF
+               -DCMARK_SHARED=ON
+               -DCMARK_STATIC=OFF
+               -DCMARK_TESTS="$(usex test)"
+       )
+       cmake-utils_src_configure
+}