dev-python/pykwalify: New package, ebuild written by me
authorJustin Lecher <jlec@gentoo.org>
Thu, 27 Aug 2015 15:35:56 +0000 (17:35 +0200)
committerJustin Lecher <jlec@gentoo.org>
Thu, 27 Aug 2015 15:36:05 +0000 (17:36 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pykwalify/Manifest [new file with mode: 0644]
dev-python/pykwalify/files/pykwalify-1.4.0-S.patch [new file with mode: 0644]
dev-python/pykwalify/metadata.xml [new file with mode: 0644]
dev-python/pykwalify/pykwalify-1.4.0.ebuild [new file with mode: 0644]
dev-python/pykwalify/pykwalify-9999.ebuild [new file with mode: 0644]

diff --git a/dev-python/pykwalify/Manifest b/dev-python/pykwalify/Manifest
new file mode 100644 (file)
index 0000000..5369578
--- /dev/null
@@ -0,0 +1 @@
+DIST pykwalify-1.4.0.tar.gz 23126 SHA256 25ab7c4303ca4631dd89de851535d1284a8799c7b696ddbf95056f0b615f4520 SHA512 072f646a9846122e74fb09b682abaf89b93ded52b9e32053586658a4a5a416bc51d051b1607358450324ceb963e3cd66ae487421275cc7928facdb2acede2797 WHIRLPOOL 826cd36b5f1061a60c2056d532671cca5865462805e5c6f6c9b83e149d9775f9a2ffb559d5ea8dd18986eb7dffe36710cc776e022c2d0b36fc51a1045e52b4a0
diff --git a/dev-python/pykwalify/files/pykwalify-1.4.0-S.patch b/dev-python/pykwalify/files/pykwalify-1.4.0-S.patch
new file mode 100644 (file)
index 0000000..0f133c9
--- /dev/null
@@ -0,0 +1,24 @@
+ tests/test_core.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/tests/test_core.py b/tests/test_core.py
+index 2fae7bc..0773f88 100644
+--- a/tests/test_core.py
++++ b/tests/test_core.py
+@@ -397,12 +397,12 @@ class TestCore(object):
+         ]
+         # Add override magic to make it easier to test a specific file
+-        if "S" in os.environ:
+-            pass_tests = [os.environ["S"]]
++        if "_S" in os.environ:
++            pass_tests = [os.environ["_S"]]
+             _fail_tests = []
+-        elif "F" in os.environ:
++        elif "_F" in os.environ:
+             pass_tests = []
+-            _fail_tests = [(os.environ["F"], SchemaError)]
++            _fail_tests = [(os.environ["_F"], SchemaError)]
+         for passing_test_file in pass_tests:
+             f = self.f(os.path.join("success", passing_test_file))
diff --git a/dev-python/pykwalify/metadata.xml b/dev-python/pykwalify/metadata.xml
new file mode 100644 (file)
index 0000000..c166166
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>jlec@gentoo.org</email>
+               <name>Justin Lecher</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pykwalify/pykwalify-1.4.0.ebuild b/dev-python/pykwalify/pykwalify-1.4.0.ebuild
new file mode 100644 (file)
index 0000000..23ae49c
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python lib/cli for JSON/YAML schema validation"
+HOMEPAGE="https://pypi.python.org/pypi/pykwalify https://github.com/Grokzen/pykwalify"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/docopt-0.6.2
+       >=dev-python/pyyaml-3.11
+       >=dev-python/python-dateutil-2.4.2
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/testfixtures[${PYTHON_USEDEP}]
+       )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-S.patch )
+
+python_test() {
+       py.test || die
+}
diff --git a/dev-python/pykwalify/pykwalify-9999.ebuild b/dev-python/pykwalify/pykwalify-9999.ebuild
new file mode 100644 (file)
index 0000000..7732db7
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python lib/cli for JSON/YAML schema validation"
+HOMEPAGE="https://pypi.python.org/pypi/pykwalify https://github.com/Grokzen/pykwalify"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/Grokzen/pykwalify.git"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS=""
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/docopt-0.6.2
+       >=dev-python/pyyaml-3.11
+       >=dev-python/python-dateutil-2.4.2
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/testfixtures[${PYTHON_USEDEP}]
+       )
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.0-S.patch )
+
+python_test() {
+       py.test || die
+}