media-tv/plex-media-server: 1.61.4 bump
authorStephen Shkardoon <ss23@ss23.geek.nz>
Sat, 14 Dec 2019 08:23:35 +0000 (10:23 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 14 Dec 2019 08:24:29 +0000 (10:24 +0200)
Closes: https://bugs.gentoo.org/681858
Signed-off-by: Stephen Shkardoon <ss23@ss23.geek.nz>
Closes: https://github.com/gentoo/gentoo/pull/13935
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-tv/plex-media-server/Manifest
media-tv/plex-media-server/files/virtualenv_start_pms_2019.patch [new file with mode: 0644]
media-tv/plex-media-server/metadata.xml
media-tv/plex-media-server/plex-media-server-1.16.4.ebuild [new file with mode: 0644]

index 7fea2adddd27d495b00d5b0cd118eb494a7db169..e1b06077fe61398d06a592f01dfaf15a077b12cf 100644 (file)
@@ -2,3 +2,4 @@ DIST plexmediaserver_1.11.3.4803-c40bba82e_amd64.deb 108830880 BLAKE2B 7ed912756
 DIST plexmediaserver_1.12.3.4973-215c28d86_amd64.deb 109277946 BLAKE2B 6a868943c77a1355dd0a4dbe88323b937d827dbfe84e729cf1f5c5c7d4a7d44e9af7e69121a7e3cf9f5d60786c9877bd3e303d9d5d301c86f08984afb1062730 SHA512 1befe9196926bf4cabd1f9c746e958efc72392479a844f8c3d9161282618fe28e29dbb9c12ddccf5db5b852ae58cd43dc0d988f00732431e16106021c8618347
 DIST plexmediaserver_1.13.2.5154-fd05be322_amd64.deb 111093662 BLAKE2B 26b1161107a8f9223f7065ff4119a32470c06794a159a42181b9278107a6d14f9fbb582e515223aaa659e9007d9b18299cd65b2a068e1d7dd934d52552a44cd1 SHA512 548c033272d56f6c54ab073536327b285fdbda3192c203a3ea3ff2b6c7afbc79ba7d56d7251f623ca1e09db572c92000d7baa7a8a555d853d85fdb9d1dfb8479
 DIST plexmediaserver_1.14.1.5488-cc260c476_amd64.deb 105175642 BLAKE2B 59f7cc130115ae2179bcf0ddf5ef4583886c11447c423ada2b1da62f83c3840c89aa2b6d9c56e3a358d1da03bc9a6bd340cae7fee1b6da102e9bc785de4f8e27 SHA512 48f25ac27a8dc5d1a4ae74a04793994bb21431ed3069a9808373e0c5a424fd53f577d0912e1e46a155133b094bdafb7edeb5b6c9ef428a08e07e24e055267e86
+DIST plexmediaserver_1.16.4.1469-6d5612c2f_amd64.deb 74427444 BLAKE2B f90973aaadaf8e11fbcaa0aaa817a11b62049b1eaa22c04daf65d4fc21e73eb90d982e3faa66b482fdb4e7b53467246e20845c432920718334c5419c760e85bd SHA512 0753e82d4cd2c5a35f8f62329c3013eff297edd1bf9afcfd1444c3f3f85d33b3aec4a553c70931182d3a45df44dd26ce10ddbee9b59755914c988f0edbe5aa70
diff --git a/media-tv/plex-media-server/files/virtualenv_start_pms_2019.patch b/media-tv/plex-media-server/files/virtualenv_start_pms_2019.patch
new file mode 100644 (file)
index 0000000..c68178b
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/usr/sbin/start_pms       2019-08-08 01:07:58.239646635 +0200
++++ b/usr/sbin/start_pms       2019-08-08 01:09:39.828649755 +0200
+@@ -20,6 +20,9 @@
+ test -f /etc/default/plexmediaserver && . /etc/default/plexmediaserver
++# Activate python virtualenv
++. "${PLEX_MEDIA_SERVER_HOME}"/Resources/Python/bin/activate
++
+ if [ ! -d "$PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR" ]
+ then
+   mkdir -p "$PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR"
index 1a06e96ebdc7530ab0d716fe439df6af7f725cf5..8815e575c0e371c0c8663583c76776519bb575df 100644 (file)
@@ -2,7 +2,11 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
        <maintainer type="person">
-               <email>chainsaw@gentoo.org</email>
-               <name>Tony Vroon</name>
+               <email>ss23@ss23.geek.nz</email>
+               <name>Stephen Shkardoon</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
        </maintainer>
 </pkgmetadata>
diff --git a/media-tv/plex-media-server/plex-media-server-1.16.4.ebuild b/media-tv/plex-media-server/plex-media-server-1.16.4.ebuild
new file mode 100644 (file)
index 0000000..69d4dcc
--- /dev/null
@@ -0,0 +1,121 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils systemd unpacker pax-utils python-single-r1
+
+MINOR_VERSION="1469-6d5612c2f"
+
+_APPNAME="plexmediaserver"
+_USERNAME="plex"
+_SHORTNAME="${_USERNAME}"
+_FULL_VERSION="${PV}.${MINOR_VERSION}"
+
+URI="https://downloads.plex.tv/plex-media-server-new"
+
+DESCRIPTION="A free media library that is intended for use with a plex client"
+HOMEPAGE="https://www.plex.tv/"
+SRC_URI="amd64? ( ${URI}/${_FULL_VERSION}/debian/plexmediaserver_${_FULL_VERSION}_amd64.deb )"
+SLOT="0"
+LICENSE="Plex"
+RESTRICT="bindist strip"
+KEYWORDS="-* ~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="dev-python/virtualenv[${PYTHON_USEDEP}]"
+
+RDEPEND="
+       net-dns/avahi
+       acct-user/plex
+       acct-group/plex
+       ${PYTHON_DEPS}"
+
+QA_DESKTOP_FILE="usr/share/applications/plexmediamanager.desktop"
+QA_PREBUILT="*"
+QA_MULTILIB_PATHS=(
+       "usr/lib/${_APPNAME}/.*"
+       "usr/lib/${_APPNAME}/Resources/Python/lib/python2.7/.*"
+)
+
+BINS_TO_PAX_MARK=( "${ED}/usr/lib/plexmediaserver/Plex Script Host" )
+
+S="${WORKDIR}"
+PATCHES=( "${FILESDIR}/virtualenv_start_pms_2019.patch" )
+
+src_unpack() {
+       unpack_deb ${A}
+}
+
+src_install() {
+       # Move the config to the correct place
+       local config_vanilla="/etc/default/plexmediaserver"
+       local config_path="/etc/${_SHORTNAME}"
+       dodir "${config_path}"
+       insinto "${config_path}"
+       doins "${config_vanilla#/}"
+       sed -e "s#${config_vanilla}#${config_path}/${_APPNAME}#g" -i "${S}"/usr/sbin/start_pms || die
+
+       # Remove Debian specific files
+       rm -r "usr/share/doc" || die
+
+       # Copy main files over to image and preserve permissions so it is portable
+       cp -rp usr/ "${ED}"/ || die
+
+       # Make sure the logging directory is created
+       local logging_dir="/var/log/pms"
+       dodir "${logging_dir}"
+       fowners "${_USERNAME}":"${_USERNAME}" "${logging_dir}"
+       keepdir "${logging_dir}"
+
+       # Create default library folder with correct permissions
+       local default_library_dir="/var/lib/${_APPNAME}"
+       dodir "${default_library_dir}"
+       fowners "${_USERNAME}":"${_USERNAME}" "${default_library_dir}"
+       keepdir "${default_library_dir}"
+
+       # Install the OpenRC init/conf files
+       doinitd "${FILESDIR}/init.d/${PN}"
+       doconfd "${FILESDIR}/conf.d/${PN}"
+
+       # Mask Plex libraries so that revdep-rebuild doesn't try to rebuild them.
+       # Plex has its own precompiled libraries.
+       _mask_plex_libraries_revdep
+
+       # Install systemd service file
+       systemd_newunit "${FILESDIR}/systemd/${PN}.service" "${PN}.service"
+
+       # Add pax markings to some binaries so that they work on hardened setup
+       for f in "${BINS_TO_PAX_MARK[@]}"; do
+               pax-mark m "${f}"
+       done
+
+       einfo "Configuring virtualenv"
+       virtualenv -v --no-pip --no-setuptools --no-wheel "${ED}"/usr/lib/plexmediaserver/Resources/Python || die
+       pushd "${ED}"/usr/lib/plexmediaserver/Resources/Python &>/dev/null || die
+       find . -type f -exec sed -i -e "s#${D}##g" {} + || die
+       popd &>/dev/null || die
+}
+
+pkg_postinst() {
+       elog "Plex Media Server is now installed. Please check the configuration"
+       elog "file in /etc/${_SHORTNAME}/${_APPNAME}"
+       elog "to verify the default settings."
+       elog "To start the Plex Server, run 'rc-config start plex-media-server',"
+       elog "you will then be able to access your library at"
+       elog "http://<ip>:32400/web/"
+}
+
+# Adds the precompiled plex libraries to the revdep-rebuild's mask list
+# so it doesn't try to rebuild libraries that can't be rebuilt.
+_mask_plex_libraries_revdep() {
+       dodir /etc/revdep-rebuild/
+
+       # Bug: 659702. The upstream plex binary installs its precompiled package to /usr/lib.
+       # Due to profile 17.1 splitting /usr/lib and /usr/lib64, we can no longer rely
+       # on the implicit symlink automatically satisfying our revdep requirement when we use $(get_libdir).
+       # Thus we will match upstream's directory automatically. If upstream switches their location,
+       # then so should we.
+       echo "SEARCH_DIRS_MASK=\"${EPREFIX}/usr/lib/plexmediaserver\"" > "${ED}"/etc/revdep-rebuild/80plexmediaserver
+}