sys-apps/dstat: avoid running network... etc tests
authorPaul Healy <lmiphay@gmail.com>
Tue, 2 Oct 2018 17:52:58 +0000 (18:52 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 7 Oct 2018 21:06:41 +0000 (23:06 +0200)
This fixes the test target to only load a restricted
number of the shipped plugins - network, db,
virtualisation... etc will fail in different ways
unless the environment or explicit dependencies are
met.

Closes: https://bugs.gentoo.org/638728
Closes: https://bugs.gentoo.org/656514

Signed-off-by: Paul Healy <lmiphay@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/10046
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-apps/dstat/dstat-0.7.3.ebuild
sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch [new file with mode: 0644]

index cbdd1df1a54c1dde1836958e1191665c2fc1267c..372d70a1fd0a6d0f1e38623ceef252c4e28507e3 100644 (file)
@@ -24,6 +24,8 @@ RDEPEND="
        )"
 DEPEND=""
 
+PATCHES=( "${FILESDIR}/dstat-${PV}-skip-non-sandbox-tests.patch" )
+
 src_install() {
        emake DESTDIR="${ED}" install
        einstalldocs
diff --git a/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch b/sys-apps/dstat/files/dstat-0.7.3-skip-non-sandbox-tests.patch
new file mode 100644 (file)
index 0000000..48eb542
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/Makefile 2016-03-18 13:03:22.000000000 +0000
++++ b/Makefile 2018-10-02 11:11:00.344942941 +0100
+@@ -32,9 +32,11 @@
+       rm -f examples/*.pyc plugins/*.pyc
+       $(MAKE) -C docs clean
++TEST_PLUGINS=--cpufreq --disk-avgqu --disk-avgrq --disk-svctm --disk-tps --disk-util --disk-wait --dstat-cpu --dstat-ctxt --dstat-mem --dstat --helloworld --md-status --net-packets --proc-count --snooze --test --top-bio-adv --top-bio --top-childwait --top-cpu-adv --top-cpu --top-cputime-avg --top-cputime --top-int --top-io-adv --top-io --top-latency-avg --top-latency --top-mem --top-oom
++
+ test:
+       ./dstat -taf 1 5
+-      ./dstat -t --all-plugins 1 5
++      ./dstat -t $(TEST_PLUGINS) 1 5
+ dist: clean
+       $(MAKE) -C docs dist