projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b299f63
)
dev-ruby/http: fix tests
author
Hans de Graaff
<graaff@gentoo.org>
Sun, 4 Oct 2015 06:53:49 +0000
(08:53 +0200)
committer
Hans de Graaff
<graaff@gentoo.org>
Sun, 4 Oct 2015 06:54:13 +0000
(08:54 +0200)
Avoid specs that require network access.
Package-Manager: portage-2.2.20.1
dev-ruby/http/http-0.9.8.ebuild
patch
|
blob
|
history
diff --git
a/dev-ruby/http/http-0.9.8.ebuild
b/dev-ruby/http/http-0.9.8.ebuild
index 196ca4884993028f4114413c52ed29e9dbe8b454..d4751d420f15d9efc140376f69fe5c3a1aef9214 100644
(file)
--- a/
dev-ruby/http/http-0.9.8.ebuild
+++ b/
dev-ruby/http/http-0.9.8.ebuild
@@
-32,4
+32,10
@@
ruby_add_bdepend "
all_ruby_prepare() {
sed -i -e '/simplecov/,/end/ s:^:#:' \
-e '1irequire "cgi"' spec/spec_helper.rb || die
+
+ # Avoid specs that require network access
+ sed -i -e '/.persistent/,/^ end/ s:^:#:' \
+ spec/lib/http_spec.rb || die
+ sed -i -e '/with non-ASCII URLs/,/^ end/ s:^:#:' \
+ spec/lib/http/client_spec.rb || die
}