net-p2p/bitcoind-0.16.3: Migrate from user eclass to GLEP 81
authorLuke Dashjr <luke-jr+git@utopios.org>
Mon, 30 Sep 2019 03:29:09 +0000 (03:29 +0000)
committerCraig Andrews <candrews@gentoo.org>
Sat, 7 Mar 2020 21:15:14 +0000 (16:15 -0500)
Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org>
Signed-off-by: Craig Andrews <candrews@gentoo.org>
net-p2p/bitcoind/bitcoind-0.16.3.ebuild

index 585ba9254842c703394f8f84d427275bdc9ede0f..9acfda6cbef6474fe894183b8160223fdd71e404 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 
 DB_VER="4.8"
-inherit autotools bash-completion-r1 db-use systemd user
+inherit autotools bash-completion-r1 db-use systemd
 
 BITCOINCORE_COMMITHASH="49e34e288005a5b144a642e197b628396f5a0765"
 KNOTS_PV="${PV}.knots20180918"
@@ -24,6 +24,8 @@ IUSE="+asm examples knots libressl test upnp +wallet zeromq"
 RESTRICT="!test? ( test )"
 
 DEPEND="
+       acct-group/bitcoin
+       acct-user/bitcoin
        >=dev-libs/boost-1.52.0:=[threads(+)]
        dev-libs/libevent:=
        >=dev-libs/libsecp256k1-0.0.0_pre20151118:=[recovery]
@@ -56,11 +58,6 @@ pkg_pretend() {
        elog "of receive order. To disable RBF, set mempoolreplacement=never in bitcoin.conf"
 }
 
-pkg_setup() {
-       enewgroup bitcoin
-       enewuser bitcoin -1 -1 /var/lib/bitcoin bitcoin
-}
-
 src_prepare() {
        sed -i 's/^\(complete -F _bitcoind bitcoind\) bitcoin-qt$/\1/' contrib/${PN}.bash-completion || die