dev-ml/yojson: bump to 1.3.2
authorAlexis Ballier <aballier@gentoo.org>
Wed, 2 Mar 2016 14:40:25 +0000 (15:40 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 2 Mar 2016 19:29:06 +0000 (20:29 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/yojson/Manifest
dev-ml/yojson/yojson-1.3.2.ebuild [new file with mode: 0644]

index de71dd1260bfc4fa4cb0fad3faa7780566b435ec..cc0ed97bc46bf17e54e8c080ad35cf2da858a555 100644 (file)
@@ -1,2 +1,3 @@
 DIST yojson-1.3.0.tar.gz 26610 SHA256 80e26e6d902c57bbacf44467f2a5cc30e4e189260093c66a3269fb1b1cc37094 SHA512 65e2d5bb7649cad3d395ec8fead11b18fd0ca5e59e87194a39a77561bcdaa04cecdc71f0da32ac268a36c0e7b21f56e9f40a08610f84cf7f81d0da20daf90fc0 WHIRLPOOL ed5ba5a5c397d47616282272573f9940d02035698a45dc7bc377c1fb2918d4a72fc789a4332ff7c09113d6bdcb223e2321f46f21f9576ff85197825bdc661d0d
 DIST yojson-1.3.1.tar.gz 26725 SHA256 ea97f150bb8270730165f7727518aa533c784b84f17016d339060161250124b8 SHA512 f0fb6dad88f75d279a4341384238d4b6fd63c7b34a5a7892fbf278604a4011ea744c355377246e92595696fc5a5298968802c40a12a3ddcd89412ee1ce1e1402 WHIRLPOOL 558cc3258ee4e27a4507c1383d5e2fc6542d2f8178430d73020b37184624df2879a56cee30cc9844d0531f2f1199613591500cf888f606b1788dd3c166e0b7dc
+DIST yojson-1.3.2.tar.gz 26928 SHA256 eff510621efd6dcfb86b65eaf1d4d6f3b9b680143d88e652b6f14072523a2351 SHA512 9bdda0bdeea1988f37b4b56154995dc0f5391de659ba15f452d0755afcbd213ef0d5b1ec8fd691bb4e25e99af866b4c282b078a49208f61c51eaea8e21733509 WHIRLPOOL 7973dbbf7e2b74ac82f39261f7db6ec6952e624d05c35c5ba8fd426153d148b17c0dba8a510128c1598ea17a5fe5190417e9b8cf6a9a9473c4a16e7c34489760
diff --git a/dev-ml/yojson/yojson-1.3.2.ebuild b/dev-ml/yojson/yojson-1.3.2.ebuild
new file mode 100644 (file)
index 0000000..cab42fd
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+       dev-ml/easy-format:=[ocamlopt]
+       dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+       dev-ml/cppo
+"
+
+src_compile() {
+       emake -j1
+}
+
+src_install() {
+       dodir /usr/bin
+       findlib_src_install BINDIR="${ED}"/usr/bin
+       dodoc README.md Changes
+       if use examples ; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}