dev-util/cscope: addp Prefix changes and keywords, bug #607712
authorFabian Groffen <grobian@gentoo.org>
Tue, 31 Jan 2017 11:55:34 +0000 (12:55 +0100)
committerFabian Groffen <grobian@gentoo.org>
Tue, 31 Jan 2017 11:56:16 +0000 (12:56 +0100)
Package-Manager: portage-2.3.3

dev-util/cscope/cscope-15.8a-r2.ebuild [new file with mode: 0644]
dev-util/cscope/files/cscope-15.6-darwin.patch [new file with mode: 0644]

diff --git a/dev-util/cscope/cscope-15.8a-r2.ebuild b/dev-util/cscope/cscope-15.8a-r2.ebuild
new file mode 100644 (file)
index 0000000..a62cc63
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools elisp-common toolchain-funcs
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2:0=
+       emacs? ( virtual/emacs )"
+DEPEND="${RDEPEND}
+       sys-devel/flex
+       virtual/pkgconfig
+       virtual/yacc"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+       eapply "${FILESDIR}/${PN}-15.7a-ocs-sysdir.patch" #269305
+       eapply "${FILESDIR}/${PN}-15.6-darwin.patch"
+       eapply_user
+       mv configure.{in,ac} || die
+       eautoreconf               # prevent maintainer mode later on
+}
+
+src_configure() {
+       econf --with-ncurses="${EPREFIX}"/usr
+}
+
+src_compile() {
+       emake CURSES_LIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+       if use emacs; then
+               cd "${S}"/contrib/xcscope || die
+               elisp-compile *.el
+       fi
+}
+
+src_install() {
+       default
+
+       if use emacs; then
+               cd "${S}"/contrib/xcscope || die
+               elisp-install ${PN} *.el *.elc
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+               dobin cscope-indexer
+       fi
+
+       cd "${S}"/contrib/webcscope || die
+       docinto webcscope
+       dodoc INSTALL TODO cgi-lib.pl cscope hilite.c
+       docinto webcscope/icons
+       dodoc icons/*.gif
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}
diff --git a/dev-util/cscope/files/cscope-15.6-darwin.patch b/dev-util/cscope/files/cscope-15.6-darwin.patch
new file mode 100644 (file)
index 0000000..e755f32
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/constants.h
++++ b/src/constants.h
+@@ -103,7 +103,7 @@
+ #define INCLUDES      8
+ #define       FIELDS          9
+-#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__
++#if (BSD || V9) && !__NetBSD__ && !__FreeBSD__ && !__MACH__
+ # define TERMINFO     0       /* no terminfo curses */
+ #else
+ # define TERMINFO     1