sys-apps/i2c-tools: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Fri, 15 Dec 2017 06:59:13 +0000 (07:59 +0100)
committerJeroen Roovers <jer@gentoo.org>
Fri, 15 Dec 2017 06:59:30 +0000 (07:59 +0100)
Package-Manager: Portage-2.3.18, Repoman-2.3.6

sys-apps/i2c-tools/Manifest
sys-apps/i2c-tools/i2c-tools-4.0.ebuild [new file with mode: 0644]

index aba4e2c12ad493e4e93892b03c7eced78ab8d5d4..a21d52b725be30e83a3456593060eec368e85475 100644 (file)
@@ -1 +1,2 @@
 DIST i2c-tools-3.1.1.tar.bz2 71789 BLAKE2B 0a7a3db6a3b396cfb8d5e58d8c83cae4e52239786502c6552d971350f7fc05a1ce9d7d89e9cdb154a21ac15bdf34aa0dec9501ea45317ec9c5d9fc211780bbf1 SHA512 b91f89b803e5558d49ce63f42f6542438f4f47927e4ce420cd9df989cab14a5c55d971befed73e8f793b0cf4aa41936c0ef519e5a407dceb2c08964461e803c5
+DIST i2c-tools-4.0.tar.xz 79972 BLAKE2B 982e4139ed0e2111f9e082d0690fcc0f86f97a433e292e9464b41991f14a1f90147a3612172bad6880f0df6896612e1dea0ae7bf6f459758b2cff45fb35a5dc7 SHA512 ddf86c357c101388193581bc40285089e6ab5e8d870f8aa5d594acc7ecb8596fbd30501e147b88bdea0200b1be88bc0a374356c188d1bcb067bf8e254e3dc51e
diff --git a/sys-apps/i2c-tools/i2c-tools-4.0.ebuild b/sys-apps/i2c-tools/i2c-tools-4.0.ebuild
new file mode 100644 (file)
index 0000000..44fc134
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+DISTUTILS_OPTIONAL="1"
+
+inherit flag-o-matic multilib toolchain-funcs distutils-r1
+
+DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
+HOMEPAGE="https://www.kernel.org/pub/software/utils/i2c-tools"
+SRC_URI="${HOMEPAGE}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="!<sys-apps/lm_sensors-3
+       python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+       default
+       use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+       use python && distutils-r1_src_configure
+}
+
+src_compile() {
+       emake all-lib CC=$(tc-getCC) # parallel make
+       emake CC=$(tc-getCC)
+       emake -C eepromer CC=$(tc-getCC)
+       if use python ; then
+               cd py-smbus || die
+               append-cppflags -I../include
+               distutils-r1_src_compile
+       fi
+}
+
+src_install() {
+       emake install libdir=$(get_libdir) prefix="${D}"/usr
+       dosbin eepromer/eeprom{,er}
+       rm -rf "${D}"/usr/include # part of linux-headers
+       dodoc CHANGES README
+       local d
+       for d in eeprom eepromer ; do
+               docinto ${d}
+               dodoc ${d}/README*
+       done
+
+       if use python ; then
+               cd py-smbus || die
+               docinto py-smbus
+               dodoc README*
+               distutils-r1_src_install
+       fi
+}