net-dns/avahi: port to GLEP 81, bug #701212
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 8 Dec 2019 18:58:30 +0000 (13:58 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 8 Dec 2019 18:58:50 +0000 (13:58 -0500)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
net-dns/avahi/avahi-0.7-r4.ebuild [moved from net-dns/avahi/avahi-0.7-r3.ebuild with 95% similarity]

similarity index 95%
rename from net-dns/avahi/avahi-0.7-r3.ebuild
rename to net-dns/avahi/avahi-0.7-r4.ebuild
index 9295cc5587fe1ac647f8b56c75e705e3008aa3af..3891e557578aac9a97d2bb18029f8cbe2a7e488f 100644 (file)
@@ -6,7 +6,7 @@ EAPI="7"
 PYTHON_COMPAT=( python2_7 )
 PYTHON_REQ_USE="gdbm"
 
-inherit autotools eutils flag-o-matic multilib multilib-minimal mono-env python-r1 systemd user
+inherit autotools eutils flag-o-matic multilib multilib-minimal mono-env python-r1 systemd
 
 DESCRIPTION="System which facilitates service discovery on a local network"
 HOMEPAGE="http://avahi.org/"
@@ -51,7 +51,15 @@ DEPEND="
                >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
        )
 "
-RDEPEND="${DEPEND}
+RDEPEND="
+       acct-user/avahi
+       acct-group/avahi
+       acct-group/netdev
+       autoipd? (
+               acct-user/avahi-autoipd
+               acct-group/avahi-autoipd
+       )
+       ${DEPEND}
        howl-compat? ( !net-misc/howl )
        mdnsresponder-compat? ( !net-misc/mDNSResponder )
        selinux? ( sec-policy/selinux-avahi )
@@ -71,17 +79,6 @@ PATCHES=(
        "${FILESDIR}/${P}-CVE-2017-6519.patch"
 )
 
-pkg_preinst() {
-       enewgroup netdev
-       enewgroup avahi
-       enewuser avahi -1 -1 -1 avahi
-
-       if use autoipd; then
-               enewgroup avahi-autoipd
-               enewuser avahi-autoipd -1 -1 -1 avahi-autoipd
-       fi
-}
-
 pkg_setup() {
        use mono && mono-env_pkg_setup
 }