sys-process/pidof-bsd: remove last rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 3 Nov 2019 17:04:11 +0000 (20:04 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 3 Nov 2019 17:05:12 +0000 (20:05 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sys-process/pidof-bsd/Manifest [deleted file]
sys-process/pidof-bsd/files/pidof-bsd-20050501-fbsd11.patch [deleted file]
sys-process/pidof-bsd/files/pidof-bsd-20050501-firstarg.patch [deleted file]
sys-process/pidof-bsd/files/pidof-bsd-20050501-gfbsd.patch [deleted file]
sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch [deleted file]
sys-process/pidof-bsd/metadata.xml [deleted file]
sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild [deleted file]

diff --git a/sys-process/pidof-bsd/Manifest b/sys-process/pidof-bsd/Manifest
deleted file mode 100644 (file)
index b1e138b..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST pidof-bsd-20050501.tar.gz 1769 BLAKE2B 6f64d23913e08adc52eef5550becb7f54a1eab805e1a7fe7883632756647bb633d617486fb7a4fa09459d32cdcfb09f41b5c157cc877a71fb07744e2cfced562 SHA512 27691305165848363415a7d487b36a87db0750a9c08e6327eef05f5e87326c91fbf46c415673f83268981a22bbfcfaaf5ef280c06c24b3ebb50d1483527f9c94
diff --git a/sys-process/pidof-bsd/files/pidof-bsd-20050501-fbsd11.patch b/sys-process/pidof-bsd/files/pidof-bsd-20050501-fbsd11.patch
deleted file mode 100644 (file)
index 4a1b162..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/pidof/Makefile b/pidof/Makefile
-index d2d760b..67d2725 100644
---- a/pidof/Makefile
-+++ b/pidof/Makefile
-@@ -2,8 +2,7 @@
- PROG= pidof
- SRCS= pidof.c
--NOMAN=        yes
-+NO_MAN=       yes
- LDADD=        -lkvm
--LINKS=        ${BINDIR}/pidof
- .include <bsd.prog.mk>
diff --git a/sys-process/pidof-bsd/files/pidof-bsd-20050501-firstarg.patch b/sys-process/pidof-bsd/files/pidof-bsd-20050501-firstarg.patch
deleted file mode 100644 (file)
index dfb15ae..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: pidof/pidof.c
-===================================================================
---- pidof.orig/pidof.c
-+++ pidof/pidof.c
-@@ -67,7 +67,7 @@ get_pid_of_process(const char *process_n
-                                       char **p_argv = NULL;
-                                       
-                                       if ((p_argv = kvm_getargv(kd, p+i, 0)) != NULL)
--                                              for (; *p_argv != NULL; p_argv++)
-+                                              if ( *p_argv != NULL )
-                                                       if (strcmp(process_name, basename(*p_argv)) == 0) {
-                                                               (void)printf("%d ", (int)p[i].ki_pid);
-                                                               processes_found++;
diff --git a/sys-process/pidof-bsd/files/pidof-bsd-20050501-gfbsd.patch b/sys-process/pidof-bsd/files/pidof-bsd-20050501-gfbsd.patch
deleted file mode 100644 (file)
index bb7a776..0000000
+++ /dev/null
@@ -1,128 +0,0 @@
-? .pidof.c.swp
-? pidof
-? pidof.core
-Index: pidof.c
-===================================================================
-RCS file: /cvsroot/bmp-plugins/pidof/pidof.c,v
-retrieving revision 1.4
-diff -u -r1.4 pidof.c
---- pidof.c    1 May 2005 16:26:19 -0000       1.4
-+++ pidof.c    13 Sep 2005 16:11:08 -0000
-@@ -26,6 +26,7 @@
-  * $Id$
-  */
-+#include <unistd.h>
- #include <stdio.h>
- #include <string.h>
- #include <err.h>
-@@ -37,56 +38,91 @@
- #include <fcntl.h>
- #include <stdlib.h>
- #include <sysexits.h>
-+#include <libgen.h>
--static int    get_pid_of_process(char *process_name);
-+static int    get_pid_of_process(const char *process_name);
- static void   usage(void);
-+static int match_argv;
-+static pid_t own_pid;
-+
- static int
--get_pid_of_process(char *process_name)
-+get_pid_of_process(const char *process_name)
- {
-       static kvm_t *kd = NULL;
-       struct kinfo_proc *p;
--      int i, n_processes, processes_found;
--
--      processes_found = 0;
-+      int i, n_processes, 
-+          processes_found = 0;
-       
-       if ((kd = kvm_open("/dev/null", "/dev/null", "/dev/null", O_RDONLY, "kvm_open")) == NULL) 
-                        (void)errx(1, "%s", kvm_geterr(kd));
-       else {
-               p = kvm_getprocs(kd, KERN_PROC_PROC, 0, &n_processes);
--              for (i = 0; i<n_processes; i++)
--                      if (strncmp(process_name, p[i].ki_comm, COMMLEN+1) == 0) {
--                              (void)printf("%d ", (int)p[i].ki_pid);
--                              processes_found++;
--                      }
-+              for (i = 0; i<n_processes; i++) {
-+                      if (p[i].ki_pid != own_pid)
-+                              if (strncmp(process_name, p[i].ki_comm, COMMLEN+1) == 0) {
-+                                      (void)printf("%d ", (int)p[i].ki_pid);
-+                                      processes_found++;
-+                              } else if (match_argv == 1) {
-+                                      char **p_argv = NULL;
-+                                      
-+                                      if ((p_argv = kvm_getargv(kd, p+i, 0)) != NULL)
-+                                              for (; *p_argv != NULL; p_argv++)
-+                                                      if (strcmp(process_name, basename(*p_argv)) == 0) {
-+                                                              (void)printf("%d ", (int)p[i].ki_pid);
-+                                                              processes_found++;
-+                                                              break;
-+                                                      }
-+                              }
-+              }
-               kvm_close(kd);
-       }       
--
--      return processes_found;
-+      
-+      return (processes_found);
- }
- static void
- usage() 
- {
--      (void)fprintf(stderr, "usage: pidof name1 name2 ...\n");
-+      (void)fprintf(stderr, "usage: pidof [-x] name1 name2 ...\n");
-       exit(EX_USAGE);
- }
- int
- main(int argc, char **argv)
- {
--      int i, procs_found;
-+      int i, procs_found,
-+          ch;
-       procs_found = 0;
-+      match_argv = 0;
--      if (argc <= 1)
--              usage();
-+      own_pid = getpid();
-+      
-+      while ((ch = getopt(argc, argv, "x")) != -1) {
-+              switch (ch) {
-+              case 'x':
-+                      match_argv = 1;
-+                      break;
-+              case '?':
-+              default:
-+                      usage();
-+                      break;
-+              }
-+      }
-+      argc -= optind;
-+      argv += optind;
--      for (i = 1; i<argc; procs_found += get_pid_of_process(argv[i++]));
-+      if (argc < 1)
-+              usage();
-+      
-+      for (i = 0; i<argc; i++) {
-+              procs_found += get_pid_of_process(argv[i]);
-+      }
-       (void)printf("\n");
-       
--      return (procs_found > 0) ? 0 : 1;
-+      return ((procs_found > 0) ? 0 : 1);
- }
diff --git a/sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch b/sys-process/pidof-bsd/files/pidof-bsd-20050501-pname.patch
deleted file mode 100644 (file)
index 13e890c..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/pidof.c  2006-09-21 15:14:03 +0100
-+++ b/pidof.c  2006-09-21 15:13:47 +0100
-@@ -53,14 +53,22 @@
-       struct kinfo_proc *p;
-       int i, n_processes, 
-           processes_found = 0;
-+      char *pname = NULL;
-+
-+      if (process_name == NULL)
-+              return 0;
-+
-+      if ((pname = strdup(basename(process_name))) == NULL)
-+              return 0;
-       
--      if ((kd = kvm_open("/dev/null", "/dev/null", "/dev/null", O_RDONLY, "kvm_open")) == NULL) 
--                       (void)errx(1, "%s", kvm_geterr(kd));
--      else {
-+      if ((kd = kvm_open("/dev/null", "/dev/null", "/dev/null", O_RDONLY, NULL)) == NULL) {
-+              free(pname);
-+              (void)errx(1, "%s", kvm_geterr(kd));
-+      } else {
-               p = kvm_getprocs(kd, KERN_PROC_PROC, 0, &n_processes);
-               for (i = 0; i<n_processes; i++) {
-                       if (p[i].ki_pid != own_pid)
--                              if (strncmp(process_name, p[i].ki_comm, COMMLEN+1) == 0) {
-+                              if (strncmp(pname, p[i].ki_comm, COMMLEN+1) == 0) {
-                                       (void)printf("%d ", (int)p[i].ki_pid);
-                                       processes_found++;
-                               } else if (match_argv == 1) {
-@@ -68,7 +76,7 @@
-                                       
-                                       if ((p_argv = kvm_getargv(kd, p+i, 0)) != NULL)
-                                               if ( *p_argv != NULL )
--                                                      if (strcmp(process_name, basename(*p_argv)) == 0) {
-+                                                      if (strcmp(pname, basename(*p_argv)) == 0) {
-                                                               (void)printf("%d ", (int)p[i].ki_pid);
-                                                               processes_found++;
-                                                               break;
-@@ -77,6 +85,7 @@
-               }
-               kvm_close(kd);
-+              free(pname);
-       }       
-       
-       return (processes_found);
diff --git a/sys-process/pidof-bsd/metadata.xml b/sys-process/pidof-bsd/metadata.xml
deleted file mode 100644 (file)
index 6f49eba..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild b/sys-process/pidof-bsd/pidof-bsd-20050501-r4.ebuild
deleted file mode 100644 (file)
index cc88235..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit bsdmk
-
-DESCRIPTION="pidof(1) utility for *BSD"
-HOMEPAGE="https://people.freebsd.org/~novel/pidof.html"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-DEPEND="sys-freebsd/freebsd-mk-defs"
-RDEPEND="!sys-process/psmisc"
-
-S="${WORKDIR}/pidof"
-
-PATCHES=( "${FILESDIR}/${P}-gfbsd.patch"
-       "${FILESDIR}/${P}-firstarg.patch"
-       "${FILESDIR}/${P}-pname.patch"
-       "${FILESDIR}/${P}-fbsd11.patch" )
-
-src_prepare() {
-       epatch "${PATCHES[@]}"
-}
-
-src_install() {
-       into /
-       dobin pidof
-}