dev-python/yubiotp: Support both, pycrypto and pycryptodome (wrt #611620)
authorJohann Schmitz <ercpe@gentoo.org>
Sat, 4 Mar 2017 07:20:34 +0000 (08:20 +0100)
committerJohann Schmitz <ercpe@gentoo.org>
Sat, 4 Mar 2017 07:21:14 +0000 (08:21 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.2

dev-python/yubiotp/yubiotp-0.2.1.ebuild

index 7c09af08235c026595d5895f50249485df1dec53..3b7f736ef7ea661b94a845ac80f5b48970c2d31b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -10,7 +10,7 @@ inherit eutils distutils-r1
 MY_PN="YubiOTP"
 MY_P="${MY_PN}-${PV}"
 
-DESCRIPTION="Python library for verifying YubiKey OTP tokens, both locally and through a Yubico web service"
+DESCRIPTION="Library for verifying YubiKey OTP tokens, both locally and through a Yubico web service"
 HOMEPAGE="https://bitbucket.org/psagers/yubiotp"
 SRC_URI="mirror://pypi/Y/${MY_PN}/${MY_P}.tar.gz"
 
@@ -23,7 +23,7 @@ IUSE="test"
 S="${WORKDIR}/${MY_P}"
 
 CDEPEND="dev-python/six[${PYTHON_USEDEP}]
-               dev-python/pycrypto[${PYTHON_USEDEP}]"
+               || ( dev-python/pycryptodome[${PYTHON_USEDEP}] dev-python/pycrypto[${PYTHON_USEDEP}] )"
 
 RDEPEND="${CDEPEND}"
 DEPEND="test? ( ${CDEPEND} )"