dev-libs/libmemcache: remove last rited package
authorMikle Kolyada <zlogene@gentoo.org>
Thu, 14 Jun 2018 09:37:42 +0000 (12:37 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Thu, 14 Jun 2018 09:37:42 +0000 (12:37 +0300)
dev-libs/libmemcache/Manifest [deleted file]
dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-implicit_pointer.patch [deleted file]
dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-inline.patch [deleted file]
dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-ppc_ftbfs.patch [deleted file]
dev-libs/libmemcache/libmemcache-1.4.0_rc2-r2.ebuild [deleted file]
dev-libs/libmemcache/metadata.xml [deleted file]

diff --git a/dev-libs/libmemcache/Manifest b/dev-libs/libmemcache/Manifest
deleted file mode 100644 (file)
index c3673d9..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST libmemcache-1.4.0.rc2.tar.bz2 301136 BLAKE2B bd30932811012e0d6e383c42fc3e61096d3a4d38f111bb70f04313119aaa1ea65c8709198b3edcad5dd136a809656dcad58603715115cc44affab333bf750302 SHA512 4b8c09c425d48d0ad040d3f01ec3c0d88babefb702b666d5cb3d10eac9993be88d00120b57b6224f7d55ae979d3136de10d5ddc793d9aa7f8b9531b5d79449d0
diff --git a/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-implicit_pointer.patch b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-implicit_pointer.patch
deleted file mode 100644 (file)
index e944ce1..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: libmemcache-1.4.0.rc2/test/benchmark/benchmark.c
-===================================================================
---- libmemcache-1.4.0.rc2.orig/test/benchmark/benchmark.c
-+++ libmemcache-1.4.0.rc2/test/benchmark/benchmark.c
-@@ -29,6 +29,7 @@
- #include "memcache.h"
-+char *strdup(const char *s1);
- double tt(const struct timeval *t1, const struct timeval *t2);
- double
diff --git a/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-inline.patch b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-inline.patch
deleted file mode 100644 (file)
index 6eba5df..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-http://bugs.gentoo.org/276571
-
---- include/memcache.h.in
-+++ include/memcache.h.in
-@@ -923,7 +923,7 @@ int        mcMemGet(mcFreeFunc *freeFunc, mcMallocFunc *mallocFunc,
-                mcMallocFunc *mallocAtomicFunc, mcReallocFunc *reallocFunc);
- /* Returns a pointer to the global context. */
--inline struct memcache_ctxt *mc_global_ctxt(void);
-+struct memcache_ctxt *mc_global_ctxt(void);
- /* The next two functions are used to setup an error handler. */
- int   mcErrSetup(mcErrFunc errFunc);
---- include/memcache/buffer.h
-+++ include/memcache/buffer.h
-@@ -63,14 +63,14 @@ struct memcache_buf        *mcm_buf_find_replace(struct memcache_ctxt *, struct memcach
- struct memcache_buf   *mcm_buf_find_replace2(struct memcache_ctxt *, struct memcache_buf *,
-                                                   const char *, struct memcache_buf *);
- int    mcm_buf_free(struct memcache_ctxt *, struct memcache_buf **);
--inline u_int32_t       mcm_buf_len(const struct memcache_ctxt *, const struct memcache_buf *);
-+u_int32_t      mcm_buf_len(const struct memcache_ctxt *, const struct memcache_buf *);
- struct memcache_buf   *mcm_buf_new(struct memcache_ctxt *);
- struct memcache_buf   *mcm_buf_new2(struct memcache_ctxt *, const char *, const u_int32_t);
- struct memcache_buf   *mcm_buf_new3(struct memcache_ctxt *, const char *);
- size_t         mcm_buf_read(struct memcache_ctxt *, struct memcache_buf *, int);
- int    mcm_buf_realloc(struct memcache_ctxt *, struct memcache_buf *, const u_int32_t);
--inline size_t  mcm_buf_remain(const struct memcache_ctxt *, const struct memcache_buf *);
--inline size_t  mcm_buf_remain_off(const struct memcache_ctxt *, const struct memcache_buf *);
-+size_t         mcm_buf_remain(const struct memcache_ctxt *, const struct memcache_buf *);
-+size_t         mcm_buf_remain_off(const struct memcache_ctxt *, const struct memcache_buf *);
- int    mcm_buf_replace(struct memcache_ctxt *, struct memcache_buf *, const char *, const u_int32_t);
- int    mcm_buf_replace2(struct memcache_ctxt *, struct memcache_buf *, const char *);
- int    mcm_buf_replace_buf(struct memcache_ctxt *, struct memcache_buf *, struct memcache_buf *);
diff --git a/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-ppc_ftbfs.patch b/dev-libs/libmemcache/files/libmemcache-1.4.0_rc2-ppc_ftbfs.patch
deleted file mode 100644 (file)
index dbeee57..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-Debian patch: 10_ftbfs_fix_powerpc.patch
-Fixing build on PowerPC
-https://bugs.gentoo.org/show_bug.cgi?id=365303
-
---- a/include/memcache.h.in
-+++ b/include/memcache.h.in
-@@ -61,6 +61,11 @@
- #ifndef MEMCACHE_H
- #define MEMCACHE_H
-+/* fix FTBFS on powerpc for Debian libmemcache */
-+#ifndef __USE_POSIX
-+#define __USE_POSIX
-+#endif
-+
- #include <netdb.h>
- #include <sys/types.h>
- #include <sys/time.h>
---- a/src/memcache.c
-+++ b/src/memcache.c
-@@ -39,12 +39,17 @@
- #include <sysexits.h>
- #include <errno.h>
- #include <sys/types.h>
--#ifdef __linux
-+
-+/* fix FTBFS on powerpc for Debian libmemcache.  I personally think this
-+ * shouldnt be the case, as Debian Bug#345587 seems to show. */
-+
-+/* #ifdef __linux */
- # ifndef __USE_POSIX
- #  define __USE_POSIX
- #warning "Working around busted-ass Linux header include problems: use FreeBSD instead"
- #warning "http://www.FreeBSD.org/ - you won't regret it"
--# endif
-+/* #endif */
-+
- #endif
- #include <sys/time.h>
- #include <sys/socket.h>
diff --git a/dev-libs/libmemcache/libmemcache-1.4.0_rc2-r2.ebuild b/dev-libs/libmemcache/libmemcache-1.4.0_rc2-r2.ebuild
deleted file mode 100644 (file)
index b3b5eb4..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils toolchain-funcs
-
-MY_P=${PN}-${PV/_/.}
-
-DESCRIPTION="C API for memcached"
-HOMEPAGE="http://people.freebsd.org/~seanc/libmemcache/"
-SRC_URI="http://people.freebsd.org/~seanc/libmemcache/${MY_P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-inline.patch
-       epatch "${FILESDIR}"/${P}-implicit_pointer.patch
-       [[ $(tc-arch) == ppc* ]] && epatch "${FILESDIR}"/${P}-ppc_ftbfs.patch
-
-       rm -rf test/unit || die
-       sed -i -e '/DIR/s,unit,,g' test/Makefile.am || die
-       sed -i \
-               -e 's,test/unit/Makefile,,g' \
-               -e '/^CFLAGS=.*Wall.*pipe/s,-Wall,${CFLAGS} -Wall,g' \
-               -e '/^OPTIMIZE=/d' \
-               -e '/^PROFILE=/d' \
-               configure.ac || die
-
-       eautoreconf
-       default
-}
-
-src_install() {
-       emake DESTDIR="${D}" install || die
-       dodoc ChangeLog
-}
diff --git a/dev-libs/libmemcache/metadata.xml b/dev-libs/libmemcache/metadata.xml
deleted file mode 100644 (file)
index 58bfe20..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="person">
-               <email>robbat2@gentoo.org</email>
-       </maintainer>
-       <maintainer type="person">
-               <email>prometheanfire@gentoo.org</email>
-       </maintainer>
-</pkgmetadata>