app-text/krop: Fix PyQt5 dependency, bug 699112
authorAndreas K. Huettel <dilfridge@gentoo.org>
Sat, 22 Feb 2020 20:12:37 +0000 (21:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 22 Feb 2020 20:12:37 +0000 (21:12 +0100)
Closes: https://bugs.gentoo.org/699112
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas K. Huettel <dilfridge@gentoo.org>
Signed-off-by: David Seifert <soap@gentoo.org>
app-text/krop/krop-0.5.1-r1.ebuild [moved from app-text/krop/krop-0.5.1.ebuild with 66% similarity]
app-text/krop/krop-9999.ebuild

similarity index 66%
rename from app-text/krop/krop-0.5.1.ebuild
rename to app-text/krop/krop-0.5.1-r1.ebuild
index 8dc3d8371c931fe26a315682c9b7b48e93ed4376..3a3c251466e480e54cb98cedefb53403a0686068 100644 (file)
@@ -1,23 +1,29 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 PYTHON_COMPAT=( python3_6 )
 
-inherit eutils distutils-r1 xdg-utils
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} == 9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
+else
+       SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+       KEYWORDS="amd64 ~x86"
+fi
 
 DESCRIPTION="A tool to crop PDF files"
 HOMEPAGE="http://arminstraub.com/software/krop"
-SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="amd64 ~x86"
 IUSE=""
 
 RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
        dev-python/PyPDF2[${PYTHON_USEDEP}]
-       dev-python/PyQt5[${PYTHON_USEDEP}]"
+       dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]"
 
 src_install() {
        distutils-r1_src_install
index b7f325ef3b8662b9863e0485533b84bc397965e5..67c084e81c676780b3cc6ae97ee41b558953d8fa 100644 (file)
@@ -23,7 +23,7 @@ IUSE=""
 
 RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
        dev-python/PyPDF2[${PYTHON_USEDEP}]
-       dev-python/PyQt5[${PYTHON_USEDEP}]"
+       dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]"
 
 src_install() {
        distutils-r1_src_install