dev-ada/gps: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 12:48:55 +0000 (13:48 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:17:41 +0000 (17:17 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-ada/gps/gps-2018-r3.ebuild [moved from dev-ada/gps/gps-2018-r2.ebuild with 94% similarity]
dev-ada/gps/gps-2019-r1.ebuild [moved from dev-ada/gps/gps-2019.ebuild with 95% similarity]

similarity index 94%
rename from dev-ada/gps/gps-2018-r2.ebuild
rename to dev-ada/gps/gps-2018-r3.ebuild
index 1551312c03789c67f80b259f7b74f352861e08e0..49dd272c9a9ddcd28c4ec214dd0d3ea947f3bf6f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -33,8 +33,10 @@ RDEPEND="${PYTHON_DEPS}
        sys-devel/clang:=
        x11-themes/adwaita-icon-theme
        x11-themes/hicolor-icon-theme
-       dev-python/pep8[${PYTHON_USEDEP}]
-       dev-python/jedi[${PYTHON_USEDEP}]"
+       $(python_gen_cond_dep '
+               dev-python/pep8[${PYTHON_MULTI_USEDEP}]
+               dev-python/jedi[${PYTHON_MULTI_USEDEP}]
+       ')"
 
 DEPEND="${RDEPEND}"
 
similarity index 95%
rename from dev-ada/gps/gps-2019.ebuild
rename to dev-ada/gps/gps-2019-r1.ebuild
index 2f20596db0048ea8c7b2f0fe9e55a23830392255..1985f108d72272d83302daf0e9d8b1ab3759db8c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -38,8 +38,10 @@ RDEPEND="${PYTHON_DEPS}
        sys-devel/clang:=
        x11-themes/adwaita-icon-theme
        x11-themes/hicolor-icon-theme
-       dev-python/pep8[${PYTHON_USEDEP}]
-       dev-python/jedi[${PYTHON_USEDEP}]"
+       $(python_gen_cond_dep '
+               dev-python/pep8[${PYTHON_MULTI_USEDEP}]
+               dev-python/jedi[${PYTHON_MULTI_USEDEP}]
+       ')"
 
 DEPEND="${RDEPEND}"