dev-python/httplib2: respin use-system-cacerts.patch
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 10 Apr 2019 17:24:02 +0000 (19:24 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 10 Apr 2019 17:24:23 +0000 (19:24 +0200)
Closes: https://bugs.gentoo.org/683010
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-python/httplib2/files/httplib2-0.12.1-use-system-cacerts.patch [new file with mode: 0644]
dev-python/httplib2/httplib2-0.12.1.ebuild

diff --git a/dev-python/httplib2/files/httplib2-0.12.1-use-system-cacerts.patch b/dev-python/httplib2/files/httplib2-0.12.1-use-system-cacerts.patch
new file mode 100644 (file)
index 0000000..e189a54
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/python2/httplib2/certs.py
++++ b/python2/httplib2/certs.py
+@@ -19,9 +19,7 @@ except ImportError:
+     pass
+-BUILTIN_CA_CERTS = os.path.join(
+-    os.path.dirname(os.path.abspath(__file__)), "cacerts.txt"
+-)
++BUILTIN_CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
+ def where():
+--- a/python3/httplib2/certs.py
++++ b/python3/httplib2/certs.py
+@@ -19,9 +19,7 @@ except ImportError:
+     pass
+-BUILTIN_CA_CERTS = os.path.join(
+-    os.path.dirname(os.path.abspath(__file__)), "cacerts.txt"
+-)
++BUILTIN_CA_CERTS = "/etc/ssl/certs/ca-certificates.crt"
+ def where():
index 0d4ac24b5236d52a0593ee776f340d43af9c9ba2..e80ad4f83e4c23f78213dc1145185b316c58d943 100644 (file)
@@ -21,7 +21,7 @@ RDEPEND="app-misc/ca-certificates"
 # tests connect to random remote sites
 RESTRICT="test"
 
-PATCHES=( "${FILESDIR}"/${PN}-0.11.3-use-system-cacerts.patch )
+PATCHES=( "${FILESDIR}"/${PN}-0.12.1-use-system-cacerts.patch )
 
 python_prepare_all() {
        chmod o+r */*egg*/* || die