dev-ruby/crack: cleanup
authorHans de Graaff <graaff@gentoo.org>
Fri, 22 Jul 2016 18:11:00 +0000 (20:11 +0200)
committerHans de Graaff <graaff@gentoo.org>
Fri, 22 Jul 2016 19:04:00 +0000 (21:04 +0200)
Package-Manager: portage-2.2.28

dev-ruby/crack/crack-0.4.2.ebuild [deleted file]

diff --git a/dev-ruby/crack/crack-0.4.2.ebuild b/dev-ruby/crack/crack-0.4.2.ebuild
deleted file mode 100644 (file)
index 9b28850..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md History"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Really simple JSON and XML parsing, ripped from Merb and Rails"
-HOMEPAGE="https://github.com/jnunemaker/crack"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x64-macos ~x64-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/minitest )"
-ruby_add_rdepend ">=dev-ruby/safe_yaml-1.0.0"
-
-each_ruby_prepare() {
-       # Remove tests which fail when run by portage but pass when run by hand
-       sed -i -e '/{"regex": \/foo.*\/}/d' test/json_test.rb || die
-       sed -i -e '/{"regex": \/foo.*\/i}/d' test/json_test.rb || die
-       sed -i -e '/{"regex": \/foo.*\/mix}/d' test/json_test.rb || die
-}
-
-each_ruby_test() {
-       ${RUBY} -Itest -Ilib -e 'Dir["test/*_test.rb"].each { |f| load f }' || die
-}