net-misc/spice-gtk: Switch live ebuild to meson
authorMichal Privoznik <mprivozn@redhat.com>
Fri, 18 Oct 2019 22:16:28 +0000 (00:16 +0200)
committerMatthias Maier <tamiko@gentoo.org>
Wed, 23 Oct 2019 22:52:13 +0000 (17:52 -0500)
The upstream abandoned autotools in favor of meson in
v0.37-32-g9837f97 (even though meson support was introduced in
previous release in v0.36~128).

Unfortunately, the 'static-libs' use flag must be dropped because
meson doesn't build static libraries by default, only if
developer write meson file in that fashion, which spice-gtk
developers didn't do.

GCONF_DEBUG eclass variable is removed too - it's banned in EAPI
6+ anyway.

Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
net-misc/spice-gtk/spice-gtk-9999.ebuild

index 22c904f6f151d511736cc464f5aeacc69c41bf84..96f51b0281d4b5833ffb012e6db0c958bf856522 100644 (file)
@@ -3,12 +3,10 @@
 
 EAPI=7
 
-GCONF_DEBUG="no"
-WANT_AUTOMAKE="1.12"
 VALA_MIN_API_VERSION="0.14"
 VALA_USE_DEPEND="vapigen"
 
-inherit autotools desktop eutils git-r3 readme.gentoo-r1 vala xdg-utils
+inherit desktop eutils git-r3 meson readme.gentoo-r1 vala xdg-utils
 
 DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
 HOMEPAGE="https://www.spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
@@ -17,7 +15,7 @@ LICENSE="LGPL-2.1"
 SLOT="0"
 EGIT_REPO_URI="https://anongit.freedesktop.org/git/spice/spice-gtk.git"
 KEYWORDS=""
-IUSE="+gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
+IUSE="+gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard usbredir vala webdav libressl"
 
 # TODO:
 # * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
@@ -80,8 +78,6 @@ src_prepare() {
 
        default
 
-       eautoreconf
-
        use vala && vala_src_prepare
 }
 
@@ -94,28 +90,22 @@ src_configure() {
        # Clean up environment, bug #586642
        xdg_environment_reset
 
-       local myconf
-       myconf="
-               $(use_with gtk3 gtk 3.0)
-               $(use_enable introspection)
-               $(use_enable mjpeg builtin-mjpeg)
-               $(use_enable policykit polkit)
-               $(use_enable pulseaudio pulse)
-               $(use_with sasl)
-               $(use_enable smartcard)
-               $(use_enable static-libs static)
-               $(use_enable usbredir)
-               $(use_with usbredir usb-acl-helper-dir /usr/libexec)
-               $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids)
-               $(use_enable vala)
-               $(use_enable webdav)
-               --disable-celt051
-               --disable-gtk-doc
-               --disable-maintainer-mode
-               --disable-werror
-               --enable-pie"
-
-       econf ${myconf}
+       local emesonargs=(
+               $(meson_feature gtk3 gtk)
+               $(meson_feature introspection)
+               $(meson_use mjpeg builtin-mjpeg)
+               $(meson_feature policykit polkit)
+               $(meson_feature pulseaudio pulse)
+               $(meson_feature sasl)
+               $(meson_feature smartcard)
+               $(meson_feature usbredir)
+               $(usex usbredir -Dusb-acl-helper-dir=/usr/libexec)
+               $(usex usbredir -Dusb-ids-path=/usr/share/misc/usb.ids)
+               $(meson_feature vala vapi)
+               $(meson_feature webdav)
+       )
+
+       meson_src_configure
 }
 
 src_compile() {
@@ -124,14 +114,11 @@ src_compile() {
        # https://bugzilla.gnome.org/show_bug.cgi?id=744135
        addpredict /dev
 
-       default
+       meson_src_compile
 }
 
 src_install() {
-       default
-
-       # Remove .la files if they're not needed
-       use static-libs || find "${D}" -name '*.la' -delete || die
+       meson_src_install
 
        make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
        readme.gentoo_create_doc