dev-libs/libfmt: 6.2.1 version bump
authorCraig Andrews <candrews@gentoo.org>
Sun, 10 May 2020 02:33:38 +0000 (22:33 -0400)
committerCraig Andrews <candrews@gentoo.org>
Sun, 10 May 2020 02:34:02 +0000 (22:34 -0400)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-libs/libfmt/Manifest
dev-libs/libfmt/libfmt-6.2.1.ebuild [new file with mode: 0644]

index 151bd564f699af3236e62117d315ddbebfe9ba82..0a0fbac1a381fd3dd7cb45cbbfd1e66dcd18d3a0 100644 (file)
@@ -1,2 +1,3 @@
 DIST libfmt-6.1.2.tar.gz 723160 BLAKE2B 36e7451a8732c62dcbf47e6d287ea582827b6196a468b8648803ea1bc9a37a5f681d87488f748d749183d97783ac7fb47a3f2aeed64fc6a684f9ee85b67ae28d SHA512 8770bf4bd2bb6d938e75e0cf1e665c41930dbd9d2a6825274a5a43cd1d85b9c9ca621bb040ed099429f0e16bddbc3399361c453eb1bf3fc01376e6ad9dd875b7
 DIST libfmt-6.2.0.tar.gz 733403 BLAKE2B c7ff69a56b90ec8df7d1af5c9934592449f2052046192aa498a6440d2aab76f10c17fa2833a41475b777dca2e3a1ae671021530bf0ef8be12443541f0f5212b3 SHA512 0003543f437bae416600a2b982eb133f65588bd36d7506fa7d883ae3133fcaf7ad825904af9b588ea22e5d91e56560aaf4243a6afa11ff6d8aace2e4bb1b0cee
+DIST libfmt-6.2.1.tar.gz 733646 BLAKE2B 74394efc67065bf7a2259f5c16521b1cc4fb08bd599fe99be86b97b712c60d8790f39d65257ab18fe95bcde3d115d97e91c41d23309596f279cf51ebd4d2957d SHA512 520ef3addfecd9796253c347e0ecf4c18ef2f86d3b1b6b714f7834741f4737f1b7ed8365d3be46c9186617898911b23680cad2ae3cb7aadaf641ab32e327b0dc
diff --git a/dev-libs/libfmt/libfmt-6.2.1.ebuild b/dev-libs/libfmt/libfmt-6.2.1.ebuild
new file mode 100644 (file)
index 0000000..78c2d74
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="MIT"
+IUSE="test"
+SLOT="0/$(ver_cut 1)"
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+       S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+               -DFMT_LIB_DIR="$(get_libdir)"
+               -DFMT_TEST=$(usex test)
+       )
+       cmake_src_configure
+}