sys-fs/e2tools: set up a sane default CC
authorMike Frysinger <vapier@gentoo.org>
Mon, 31 Aug 2015 22:12:56 +0000 (18:12 -0400)
committerMike Frysinger <vapier@gentoo.org>
Mon, 31 Aug 2015 22:13:43 +0000 (18:13 -0400)
The ancient autoconf defaults to `gcc` otherwise.

sys-fs/e2tools/e2tools-0.0.16.ebuild

index 081fb974fa417a4398aba51b66fad15ed1b54784..052ef631c0f79ce6663c60a9a0bd79317c4d8554 100644 (file)
@@ -4,6 +4,8 @@
 
 EAPI="5"
 
+inherit toolchain-funcs
+
 DESCRIPTION="utilities to read, write, and manipulate files in an ext2/ext3 filesystem"
 HOMEPAGE="http://home.earthlink.net/~k_sheff/sw/e2tools/"
 SRC_URI="http://home.earthlink.net/~k_sheff/sw/${PN}/${P}.tar.gz"
@@ -24,5 +26,6 @@ src_prepare() {
 src_configure() {
        # The configure script is ancient.
        export CONFIG_SHELL="/bin/bash"
+       tc-export CC
        default
 }