media-libs/libv4l: Fix GCC 10 / -fno-common
authorDavid Seifert <soap@gentoo.org>
Tue, 25 Feb 2020 23:37:50 +0000 (00:37 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 25 Feb 2020 23:37:50 +0000 (00:37 +0100)
Closes: https://bugs.gentoo.org/706756
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/libv4l/files/libv4l-1.16.6-gcc10-fno-common.patch [new file with mode: 0644]
media-libs/libv4l/libv4l-1.16.6.ebuild

diff --git a/media-libs/libv4l/files/libv4l-1.16.6-gcc10-fno-common.patch b/media-libs/libv4l/files/libv4l-1.16.6-gcc10-fno-common.patch
new file mode 100644 (file)
index 0000000..ea43fb8
--- /dev/null
@@ -0,0 +1,44 @@
+--- a/lib/include/libdvbv5/desc_t2_delivery.h
++++ b/lib/include/libdvbv5/desc_t2_delivery.h
+@@ -215,7 +215,7 @@
+  * @brief converts from internal representation to string the SISO_MISO
+  *      field of dvb_desc_t2_delivery:SISO_MISO field.
+  */
+-const char *siso_miso[4];
++extern const char *siso_miso[4];
+ #ifdef __cplusplus
+ }
+--- a/lib/libdvbv5/dvb-v5.h
++++ b/lib/libdvbv5/dvb-v5.h
+@@ -14,17 +14,17 @@
+       char *name;
+ };
+ extern struct fe_status_name fe_status_name[8];
+-const char *fe_code_rate_name[14];
+-const char *fe_modulation_name[15];
+-const char *fe_transmission_mode_name[10];
+-const unsigned fe_bandwidth_name[8];
+-const char *fe_guard_interval_name[12];
+-const char *fe_hierarchy_name[6];
+-const char *fe_voltage_name[4];
+-const char *fe_tone_name[3];
+-const char *fe_inversion_name[4];
+-const char *fe_pilot_name[4];
+-const char *fe_rolloff_name[5];
+-const char *dvb_v5_name[72];
+-const char *delivery_system_name[20];
++extern const char *fe_code_rate_name[14];
++extern const char *fe_modulation_name[15];
++extern const char *fe_transmission_mode_name[10];
++extern const unsigned fe_bandwidth_name[8];
++extern const char *fe_guard_interval_name[12];
++extern const char *fe_hierarchy_name[6];
++extern const char *fe_voltage_name[4];
++extern const char *fe_tone_name[3];
++extern const char *fe_inversion_name[4];
++extern const char *fe_pilot_name[4];
++extern const char *fe_rolloff_name[5];
++extern const char *dvb_v5_name[72];
++extern const char *delivery_system_name[20];
+ #endif
index 3fafe417aeccb22601624195e828e5f2187fdc7a..b518b7a921927812ade9ad55c65dec7ce559579e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="7"
@@ -29,6 +29,8 @@ BDEPEND="virtual/pkgconfig
 
 S=${WORKDIR}/${MY_P}
 
+PATCHES=( "${FILESDIR}"/${PN}-1.16.6-gcc10-fno-common.patch )
+
 pkg_setup() {
        CONFIG_CHECK="~SHMEM"
        linux-info_pkg_setup