net-libs/grpc: Fix files installed outside prefix
authorJulius Putra Tanu Setiaji <indocomsoft@gmail.com>
Mon, 6 May 2019 14:18:46 +0000 (22:18 +0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 7 May 2019 18:54:54 +0000 (11:54 -0700)
Signed-off-by: Julius Putra Tanu Setiaji <indocomsoft@gmail.com>
Closes: https://bugs.gentoo.org/685198
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Closes: https://github.com/gentoo/gentoo/pull/11916
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-libs/grpc/grpc-1.12.0.ebuild
net-libs/grpc/grpc-1.12.1-r1.ebuild
net-libs/grpc/grpc-1.13.0-r1.ebuild
net-libs/grpc/grpc-1.13.1.ebuild
net-libs/grpc/grpc-1.14.2.ebuild
net-libs/grpc/grpc-1.15.0.ebuild
net-libs/grpc/grpc-1.16.1.ebuild
net-libs/grpc/grpc-1.17.1.ebuild
net-libs/grpc/grpc-1.18.0.ebuild
net-libs/grpc/grpc-1.19.0.ebuild
net-libs/grpc/grpc-1.20.1.ebuild

index ddf193e17a0461935cfccfdfcc5bf04678f0bc43..89cc2c83087e532ccf641fa312bfe59e5495ebbd 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -59,7 +59,7 @@ src_compile() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=true \
                install
index 7f3ee9f18a8282d766d730bf0c036a9552fc693a..51e73dd8c9cc6502bf1d89a3fe520412b36db7dd 100644 (file)
@@ -134,7 +134,7 @@ python_compile_all() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=true \
                install
index 138531249bfc82de2d43f4041a7e73512f8868f6..45bfa5343f47f4ac301799fe625b59335e07dbbe 100644 (file)
@@ -138,7 +138,7 @@ python_compile_all() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index e4d1903e6797d3335db50d109c22a52754ce042e..12364479d275a77e085c34c058cb8a3d4b840f6d 100644 (file)
@@ -137,7 +137,7 @@ python_compile_all() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index b88634bc3de7fdee3e903ce4427f88e076869dbd..f3f61968210e8d070b4974f9af2351dad60d12b0 100644 (file)
@@ -137,7 +137,7 @@ python_compile_all() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index 9a98d75031c21030f05a84c42d7c98751bc4f5eb..54b506a2c3a7961b6a940c6608e69ed09ccbe93e 100644 (file)
@@ -137,7 +137,7 @@ python_compile_all() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index 4cfb0e21799cbcab70f9da24ab10a9f51eb2c634..90158c5c0d3b92e2f2da96ba5f96fc522f4a31dd 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -69,7 +69,7 @@ src_compile() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index 306060617908432b07557d4acc2fd78f05a697fd..7c7b0acf0400e25e752cfa7650b39fc66eaf4dea 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -73,7 +73,7 @@ src_compile() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index 9334110878bd4941fa69e3875c54d53aa4ec7ca1..7c7b0acf0400e25e752cfa7650b39fc66eaf4dea 100644 (file)
@@ -73,7 +73,7 @@ src_compile() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index 980578d57ee3c6ec6b35348633347d5ce968c2d3..39508cff560b4d62276bdef52dfc314a4b813b7b 100644 (file)
@@ -71,7 +71,7 @@ src_compile() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install
index 34179c7a860ee3eff53fe2dff34606d5418b7a26..f963e1b5c22f2f2777935460d2927b6f84280755 100644 (file)
@@ -71,7 +71,7 @@ src_compile() {
 
 src_install() {
        emake \
-               prefix="${D}"/usr \
+               prefix="${ED%/}"/usr \
                INSTALL_LIBDIR="$(get_libdir)" \
                STRIP=/bin/true \
                install