app-misc/pax-utils: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 20:47:02 +0000 (21:47 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 21:14:07 +0000 (22:14 +0100)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-misc/pax-utils/Manifest
app-misc/pax-utils/pax-utils-1.2.4-r1.ebuild [deleted file]

index 571ddff0d396323f32102a0bc8e27004a8932af3..edcf2c384b16bc29807ca035b2b26482ca12923d 100644 (file)
@@ -1,2 +1 @@
-DIST pax-utils-1.2.4.tar.xz 665648 BLAKE2B f0003f912e42a25c8b587764591f7c466aa4c7a24f38fe101d7b64ea5abca5511b2f9329fa5620d1b4ae1926c2272eb97d4ada0210d4e55d16c7766a055672f4 SHA512 03b84054c59e8ce64d2c07276c61245c8e9b3eca2fc430269531e2dafe120009b541ebb6adc4ff54c13a1da63caf0755fb026ba272cf17d04f75e06b893a3e95
 DIST pax-utils-1.2.5.tar.xz 679604 BLAKE2B 348c6ab52a5e950f346115802d596fd33142fe2d93a83d686fbec917d3f74c53c332f2fcbd197c5bdd38b545f48568c7b461143fa328433ce3ee931901012601 SHA512 bf2f47393a66b4218eba7981100fc6936c7c9d6d98970f5337e7b3097ce6f7b2ca13de486ff7450e4395b74ba2308d37105508234f323230376ec5814cfe54f9
diff --git a/app-misc/pax-utils/pax-utils-1.2.4-r1.ebuild b/app-misc/pax-utils/pax-utils-1.2.4-r1.ebuild
deleted file mode 100644 (file)
index cc47214..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit eutils python-single-r1 toolchain-funcs unpacker
-
-DESCRIPTION="ELF utils that can check files for security relevant properties"
-HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
-SRC_URI="mirror://gentoo/${P}.tar.xz
-       https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="caps debug python seccomp"
-
-RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
-       python? (
-               ${PYTHON_DEPS}
-               $(python_gen_cond_dep '
-                       dev-python/pyelftools[${PYTHON_MULTI_USEDEP}]
-               ')
-       )
-       seccomp? ( sys-libs/libseccomp )"
-DEPEND="${RDEPEND}
-       caps? ( virtual/pkgconfig )
-       seccomp? ( virtual/pkgconfig )
-       app-arch/xz-utils"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-_emake() {
-       emake \
-               USE_CAP=$(usex caps) \
-               USE_DEBUG=$(usex debug) \
-               USE_PYTHON=$(usex python) \
-               USE_SECCOMP=$(usex seccomp) \
-               "$@"
-}
-
-pkg_setup() {
-       if use python; then
-               python-single-r1_pkg_setup
-       fi
-}
-
-src_configure() {
-       # Avoid slow configure+gnulib+make if on an up-to-date Linux system
-       if use prefix || ! use kernel_linux ||
-               has_version '<sys-libs/glibc-2.10'
-       then
-               econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
-       else
-               tc-export CC PKG_CONFIG
-       fi
-}
-
-src_compile() {
-       _emake
-}
-
-src_test() {
-       _emake check
-}
-
-src_install() {
-       _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
-
-       use python && python_fix_shebang "${ED}"/usr/bin/lddtree
-}