dev-java/openjdk-bin: remove postinst warnings from :8
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 29 Dec 2019 08:31:49 +0000 (00:31 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Sun, 29 Dec 2019 08:36:11 +0000 (00:36 -0800)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjdk-bin/openjdk-bin-8.222_p10-r1.ebuild
dev-java/openjdk-bin/openjdk-bin-8.232_p09.ebuild

index e856f20fbf4cb42d55bbbc4d68a77bb6f45a89d8..2ff06a07bf1bdda004a8f16b81ca098dc2e5307b 100644 (file)
@@ -91,18 +91,3 @@ src_install() {
        java-vm_revdep-mask
        java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
 }
-
-pkg_postinst() {
-       java-vm-2_pkg_postinst
-
-       if use gentoo-vm ; then
-               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
-               ewarn "recognised by the system. This will almost certainly break things."
-       else
-               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
-               ewarn "will not be recognised by the system. For example, simply calling"
-               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
-               ewarn "fully supports OpenJDK 8. This JDK must therefore be invoked using its"
-               ewarn "absolute location under ${EPREFIX}/opt/${P}."
-       fi
-}
index 9af9550dd34d24e4798a7dbed3095c809f6523ab..e1c51cc17b64ea1f67604d7b738764fca4194027 100644 (file)
@@ -91,18 +91,3 @@ src_install() {
        java-vm_revdep-mask
        java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
 }
-
-pkg_postinst() {
-       java-vm-2_pkg_postinst
-
-       if use gentoo-vm ; then
-               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
-               ewarn "recognised by the system. This will almost certainly break things."
-       else
-               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
-               ewarn "will not be recognised by the system. For example, simply calling"
-               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
-               ewarn "fully supports OpenJDK 8. This JDK must therefore be invoked using its"
-               ewarn "absolute location under ${EPREFIX}/opt/${P}."
-       fi
-}