dev-python/stevedore: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 09:45:07 +0000 (10:45 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:39:06 +0000 (14:39 +0100)
dev-python/stevedore/Manifest
dev-python/stevedore/stevedore-1.20.1.ebuild [deleted file]

index a9cf77fca6527113cee51cf1bd510bf9a50ab031..b41fad6b06f19139d169e474bc65bd2658ad5168 100644 (file)
@@ -1,2 +1 @@
-DIST stevedore-1.20.1.tar.gz 505908 BLAKE2B e12891088b3b55ea0376565da51b14f23bee27ae08b9f85817333b5c6e279c58b7e2cea87779ec527cb10eb1613fed55733755842028e598f3392431b70b5b48 SHA512 7518fb4cac2ea15867a616373521169fd114152ae7e657deb26dbcf874f2442336824ded480973b4334e9b56c349abd165aab7779defc219f57d7ba7f670048c
 DIST stevedore-1.25.1.tar.gz 509014 BLAKE2B 22580ac0e5af56eadd81e7521888e3b2458a1c03a3bdac69df1f2eeef20248f1ddc1748447e3e961b61cbe62ebc939e36c04ff011b7845b3278e18a5fdc9e14e SHA512 f3d2a7360e783c800c3c2488f6adf6f9f76e34e4a4e6f3fc53d2f1114b889c443c13fdf217ddce65a41922dda2c782f19b2077847807c70e732a522fd2166ff0
diff --git a/dev-python/stevedore/stevedore-1.20.1.ebuild b/dev-python/stevedore/stevedore-1.20.1.ebuild
deleted file mode 100644 (file)
index f1c2d7d..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.python.org/pypi/stevedore"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
-               >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
-       )
-       doc? (
-               >=dev-python/pillow-2.4.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
-               >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
-               >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # Delete spurious data in requirements.txt
-       sed -e '/^pbr/d' -i requirements.txt || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-python_test() {
-       nosetests --verbosity=3 stevedore || die
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-
-       distutils-r1_python_install_all
-}