net-vpn/i2pd: remove old
authorAlexey Korepanov <kaikaikai@yandex.ru>
Sat, 15 Jun 2019 21:21:59 +0000 (22:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 18 Jun 2019 10:02:48 +0000 (12:02 +0200)
Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru>
Closes: https://github.com/gentoo/gentoo/pull/12260
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-vpn/i2pd/Manifest
net-vpn/i2pd/i2pd-2.23.0.ebuild [deleted file]

index 7209d6379ef25e9b96e407b622a31bfe457bf63d..dea49717d432892425607462f680331bf78537a9 100644 (file)
@@ -1,4 +1,3 @@
-DIST i2pd-2.23.0.tar.gz 1008677 BLAKE2B c216785d8642e1c8d7cdbcddd23e6dd0b8a1fe8d732ef8b8d19e3c7c55ad91285dfa85bcfab0934a0acc4c180750ff8e3f5730f948dafff7c283ed084afa3374 SHA512 b547fa5b4ab3fbdf51cded846966b702304cc3dcbafbf3b4fc0e93e1907e45a649dd19eabc851309dfb7d3aa8ef84eefcb2cf1a3cda8549f90200da54df06923
 DIST i2pd-2.24.0.tar.gz 1063751 BLAKE2B 22e0dd09926735d0d512fefde21da7cd6c923225f8e22f8e511a4d170781420670cc297584a01eb1200c45e1bba11f0c7e03153d3a412cf57bb2cebc0307b551 SHA512 89364943ab4d7344c3e7e79759b051710ca7ebb9021220904c112ebd6adac84fac37627c191ed06de5c4aba799a3157f680382b227499d26976ae1a742151514
 DIST i2pd-2.25.0.tar.gz 1068786 BLAKE2B 80e5e6de2ffaad86c0c3ad4a89cfa12cf3ac8cf61ae856f4647af4e06b56594f39e9d75d798d5429b372fba718f4e92ea4ea94b802929ab22d8850ba46b2827e SHA512 e45318236b7a4e23c8dc83423f4cbc62e622a6f6346a67d56af09b805a82f1d1bf4174c9785078292ad07fc7e5e75f15d3fcc801e44fddcbd8c30d6c7bd6975e
 DIST i2pd-2.26.0.tar.gz 1073024 BLAKE2B 21a59b140c0a21dec5a5b57c08ddc81530f5a2662e53d6a028ba9fd2d6c7bc89de1a49aa0f2981b6dd6dadc2ec0d84542419e100d86fcb407d3f0ae7c66e3f76 SHA512 1f0b2ca059daa9238a9bc2959a559636266252ad0858e4e941918bb195906c817de54b2379ae95d0b9813b7cae8697db335f9d6d15d0cf919e6f687a282e528c
diff --git a/net-vpn/i2pd/i2pd-2.23.0.ebuild b/net-vpn/i2pd/i2pd-2.23.0.ebuild
deleted file mode 100644 (file)
index 719f88b..0000000
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit systemd user cmake-utils eapi7-ver toolchain-funcs
-
-DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
-HOMEPAGE="https://github.com/PurpleI2P/i2pd"
-SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="cpu_flags_x86_aes cpu_flags_x86_avx i2p-hardening libressl static +upnp websocket"
-
-# if using libressl, require >=boost-1.65, see #597798
-RDEPEND="
-       !static? (
-               dev-libs/boost:=[threads]
-               !libressl? ( dev-libs/openssl:0=[-bindist] )
-               libressl? (
-                       dev-libs/libressl:0=
-                       >=dev-libs/boost-1.65:=
-               )
-               upnp? ( net-libs/miniupnpc )
-       )"
-DEPEND="${RDEPEND}
-       static? (
-               dev-libs/boost:=[static-libs,threads]
-               !libressl? ( dev-libs/openssl:0=[static-libs] )
-               libressl? (
-                       dev-libs/libressl:0=[static-libs]
-                       >=dev-libs/boost-1.65:=
-               )
-               sys-libs/zlib:=[static-libs]
-               upnp? ( net-libs/miniupnpc[static-libs] )
-       )
-       websocket? ( dev-cpp/websocketpp )"
-
-I2PD_USER=i2pd
-I2PD_GROUP=i2pd
-
-CMAKE_USE_DIR="${S}/build"
-
-DOCS=( README.md contrib/i2pd.conf contrib/tunnels.conf )
-
-PATCHES=( "${FILESDIR}/${PN}-2.14.0-fix_installed_components.patch" )
-
-pkg_pretend() {
-       if tc-is-gcc && ! ver_test "$(gcc-version)" -ge "4.7"; then
-               die "At least gcc 4.7 is required"
-       fi
-       if use i2p-hardening && ! tc-is-gcc; then
-               die "i2p-hardening requires gcc"
-       fi
-}
-
-src_configure() {
-       mycmakeargs=(
-               -DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
-               -DWITH_AVX=$(usex cpu_flags_x86_avx ON OFF)
-               -DWITH_HARDENING=$(usex i2p-hardening ON OFF)
-               -DWITH_PCH=OFF
-               -DWITH_STATIC=$(usex static ON OFF)
-               -DWITH_UPNP=$(usex upnp ON OFF)
-               -DWITH_WEBSOCKETS=$(usex websocket ON OFF)
-               -DWITH_LIBRARY=ON
-               -DWITH_BINARY=ON
-       )
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       # config
-       insinto /etc/i2pd
-       doins contrib/i2pd.conf
-       doins contrib/tunnels.conf
-
-       # grant i2pd group read and write access to config files
-       fowners "root:${I2PD_GROUP}" \
-               /etc/i2pd/i2pd.conf \
-               /etc/i2pd/tunnels.conf
-       fperms 660 \
-               /etc/i2pd/i2pd.conf \
-               /etc/i2pd/tunnels.conf
-
-       # working directory
-       keepdir /var/lib/i2pd
-       insinto /var/lib/i2pd
-       doins -r contrib/certificates
-       fowners "${I2PD_USER}:${I2PD_GROUP}" /var/lib/i2pd/
-       fperms 700 /var/lib/i2pd/
-
-       # add /var/lib/i2pd/certificates to CONFIG_PROTECT
-       doenvd "${FILESDIR}/99i2pd"
-
-       # openrc and systemd daemon routines
-       newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
-       newinitd "${FILESDIR}/i2pd-2.6.0-r3.initd" i2pd
-       systemd_newunit "${FILESDIR}/i2pd-2.6.0-r3.service" i2pd.service
-
-       # logrotate
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}/i2pd-2.6.0-r3.logrotate" i2pd
-}
-
-pkg_setup() {
-       enewgroup "${I2PD_GROUP}"
-       enewuser "${I2PD_USER}" -1 -1 /var/lib/run/i2pd "${I2PD_GROUP}"
-}
-
-pkg_postinst() {
-       if [[ -f ${EROOT%/}/etc/i2pd/subscriptions.txt ]]; then
-               ewarn
-               ewarn "Configuration of the subscriptions has been moved from"
-               ewarn "subscriptions.txt to i2pd.conf. We recommend updating"
-               ewarn "i2pd.conf accordingly and deleting subscriptions.txt."
-       fi
-}