app-arch/brotli: EAPI-7 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 5 May 2019 18:04:02 +0000 (20:04 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 8 May 2019 17:03:32 +0000 (19:03 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-arch/brotli/brotli-1.0.7.ebuild
app-arch/brotli/brotli-9999.ebuild

index 60492c59525383042c274748b6df4ce084a6e6cc..6f3e4837617dae836921ad5a564e07e87470e0eb 100644 (file)
@@ -1,13 +1,13 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
 DISTUTILS_OPTIONAL="1"
 DISTUTILS_IN_SOURCE_BUILD="1"
 
-inherit cmake-multilib distutils-r1 eapi7-ver
+inherit cmake-multilib distutils-r1
 
 DESCRIPTION="Generic-purpose lossless compression algorithm"
 HOMEPAGE="https://github.com/google/brotli"
@@ -40,7 +40,6 @@ src_prepare() {
 
 multilib_src_configure() {
        local mycmakeargs=(
-               -DBUILD_SHARED_LIBS=ON
                -DBUILD_TESTING="$(usex test)"
        )
        cmake-utils_src_configure
index 554f1fd3ffee2b2dccb4796a73d5c624447386f2..703ecf1488be6a23aadb7c40c37914718f93ec9c 100644 (file)
@@ -1,13 +1,13 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
 DISTUTILS_OPTIONAL="1"
 DISTUTILS_IN_SOURCE_BUILD="1"
 
-inherit cmake-multilib distutils-r1 eapi7-ver
+inherit cmake-multilib distutils-r1
 
 DESCRIPTION="Generic-purpose lossless compression algorithm"
 HOMEPAGE="https://github.com/google/brotli"
@@ -40,7 +40,6 @@ src_prepare() {
 
 multilib_src_configure() {
        local mycmakeargs=(
-               -DBUILD_SHARED_LIBS=ON
                -DBUILD_TESTING="$(usex test)"
        )
        cmake-utils_src_configure