media-sound/galan: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:35 +0000 (17:02 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:35 +0000 (17:02 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/galan/galan-0.3.0_beta7.ebuild

index 174e6f949b237700c9ab1eed2ef3c062afa46ecd..1ab365fd9a33cd1c62f8278ef07fa3689a2aa1ba 100644 (file)
@@ -1,7 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
+
 inherit flag-o-matic toolchain-funcs
 
 DESCRIPTION="gAlan - Graphical Audio Language"
@@ -11,25 +12,29 @@ SRC_URI="mirror://sourceforge/galan/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="vorbis alsa opengl jack"
+IUSE="alsa jack opengl vorbis"
 
-RDEPEND="x11-libs/gtk+:2
-       vorbis? ( >=media-sound/vorbis-tools-1.0 )
-       alsa? ( >=media-libs/alsa-lib-0.9.0_rc1 )
+RDEPEND="
+       media-libs/liblrdf:=
+       media-libs/ladspa-sdk
+       media-libs/audiofile:=
+       media-libs/libsndfile:=
+       sci-libs/fftw:2.1=
+       x11-libs/gtk+:2
+       alsa? ( media-libs/alsa-lib:= )
+       jack? ( virtual/jack )
        opengl? (
-               >=x11-libs/gtkglarea-1.99.0:2
+               x11-libs/gtkglarea:2=
                virtual/glu
        )
-       jack? ( >=media-sound/jack-audio-connection-kit-0.80.0 )
-       media-libs/liblrdf
-       media-libs/ladspa-sdk
-       media-libs/audiofile
-       media-libs/libsndfile
-       sci-libs/fftw:2.1"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+       vorbis? ( media-sound/vorbis-tools )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
-DOCS=( AUTHORS NEWS NOTES README TODO )
+src_prepare() {
+       default
+       rm README.w32 || die
+}
 
 src_configure() {
        # Use lrdf.pc to get -I/usr/include/raptor2 (lrdf.h -> raptor.h)
@@ -39,5 +44,8 @@ src_configure() {
 
 src_install() {
        default
-       find "${D}" -name '*.la' -exec rm -f {} +
+       dodoc NOTES
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }