app-crypt/tc-play: add libressl support and restructure USE flags
authorAnthony G. Basile <blueness@gentoo.org>
Fri, 3 Jun 2016 14:40:48 +0000 (10:40 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Fri, 3 Jun 2016 14:45:17 +0000 (10:45 -0400)
Package-Manager: portage-2.2.28

app-crypt/tc-play/tc-play-2.0-r1.ebuild [new file with mode: 0644]

diff --git a/app-crypt/tc-play/tc-play-2.0-r1.ebuild b/app-crypt/tc-play/tc-play-2.0-r1.ebuild
new file mode 100644 (file)
index 0000000..2bb6073
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="a free, pretty much fully featured and stable TrueCrypt implementation"
+HOMEPAGE="https://github.com/bwalex/tc-play"
+SRC_URI="https://github.com/bwalex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gnutls libressl"
+
+DEPEND="
+       dev-libs/libgpg-error
+       sys-fs/lvm2
+       sys-apps/util-linux
+       dev-libs/libgcrypt:0
+       gnutls? ( net-libs/gnutls )
+       !gnutls? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:0= )
+       )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+       local backend="openssl"
+       use gnutls && local backend="gcrypt"
+
+       EXTRA_MAKE_FLAGS=(
+               PBKDF_BACKEND="${backend}"
+               WARNFLAGS=""
+               CC=$(tc-getCC)
+               AR=$(tc-getAR)
+               PREFIX=/usr \
+               LIBDIR=/usr/$(get_libdir)
+       )
+}
+
+src_compile() {
+       emake -f Makefile.classic \
+               tcplay \
+               "${EXTRA_MAKE_FLAGS[@]}"
+}
+
+src_install() {
+       emake -f Makefile.classic \
+               "${EXTRA_MAKE_FLAGS[@]}" \
+               install_program \
+               DESTDIR="${ED}"
+       dodoc README.md
+}