dev-python/readthedocs-sphinx-ext: Bump to 1.0.3
authorMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 06:09:14 +0000 (08:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 22 Apr 2020 08:15:26 +0000 (10:15 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/readthedocs-sphinx-ext/Manifest
dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.3.ebuild [new file with mode: 0644]

index 850f166a662631d02f1823145f715a1d0daee2e0..bb59e412c0a3ce37df87f4e9c6507e5d2a4d36f9 100644 (file)
@@ -1 +1,2 @@
 DIST readthedocs-sphinx-ext-1.0.1.tar.gz 11545 BLAKE2B 7c671b76d47d469713bda798aef13db41ea1a4538fe571c249a4e455343f8a3d9731cbe6f688511cf69344ad728c2d394010d59e34de7295e8bf2682f23db59c SHA512 bb40f3cfd8d114ff0b9f827f20b7e1ab08c2ff3d8a8319cbd73a34e68cf604cfd1991bd0153b3a75cc48fc876fa79a24bc0e3633b099470a39d668c7667afa66
+DIST readthedocs-sphinx-ext-1.0.3.tar.gz 11589 BLAKE2B 9c6ac1bd3baa2a92cbc67d18f5fd6b3f63ce0fe7cc16832ad23940c7b8d85d88f299c8cba6623d0c2b229cbcc43e43ece926aefa01d6a3055ef9c252ddf68dfd SHA512 571336adbb3f6c9077d2530562f5d72092f8df440b282187fca5aaeb2a9c281aa49bc29423e550905696a200f692ebcea5fe6f83e023f64759224697c49e2f03
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.3.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-1.0.3.ebuild
new file mode 100644 (file)
index 0000000..e8bb844
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="https://github.com/readthedocs/readthedocs-sphinx-ext"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+       >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]"
+PDEPEND="
+       dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? ( ${PDEPEND} )"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest