remove gtk2 use flag
authorMichael Sterrett <mr_bones_@gentoo.org>
Tue, 20 Sep 2005 15:29:04 +0000 (15:29 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Tue, 20 Sep 2005 15:29:04 +0000 (15:29 +0000)
Package-Manager: portage-2.0.51.22-r2

games-emulation/mupen64-glide64/ChangeLog
games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
games-emulation/mupen64-riceplugin/ChangeLog
games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
games-emulation/mupen64/ChangeLog
games-emulation/mupen64/mupen64-0.4-r2.ebuild
games-emulation/psemu-cdr/Manifest

index 7c1520acbc02c1514543fb62ed831c7676d96047..5e7b8280e63882c5eabba1d229b04265018aff6b 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-emulation/mupen64-glide64
 # Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/ChangeLog,v 1.6 2005/03/18 16:25:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/ChangeLog,v 1.7 2005/09/20 15:22:53 mr_bones_ Exp $
+
+  20 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+  mupen64-glide64-0.7.ebuild:
+  remove gtk2 use flag
 
   18 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
   mupen64-glide64-0.7.ebuild:
index c60b71839159d2f252268bc78ac1b3f527f3341d..0e007b3fa067df9774907859c7e45e4ce5ab085d 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.6 2005/03/18 16:25:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.7 2005/09/20 15:22:53 mr_bones_ Exp $
 
 inherit flag-o-matic eutils games
 
@@ -12,13 +12,12 @@ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="x86"
-IUSE="gtk2"
+IUSE=""
 
 DEPEND="virtual/opengl
        virtual/glu
        media-libs/libsdl
-       gtk2? ( >=x11-libs/gtk+-2 )
-       !gtk2? ( =x11-libs/gtk+-1.2* )"
+       >=x11-libs/gtk+-2"
 
 S=${WORKDIR}/${MY_P}
 
@@ -26,11 +25,9 @@ src_unpack() {
        unpack ${A}
        cd "${S}"
 
-       epatch "${FILESDIR}/${P}-compile.patch"
-       epatch "${FILESDIR}/${P}-inifix.patch"
-       if use gtk2; then
-               epatch "${FILESDIR}/${P}-gtk2.patch"
-       fi
+       epatch "${FILESDIR}/${P}-compile.patch" \
+               "${FILESDIR}/${P}-inifix.patch" \
+               "${FILESDIR}/${P}-gtk2.patch"
 
        make clean || die "couldn't clean"
 
index 52f10511868a0ca84f514d0b7ae7910cb0e0f3d7..822cb568ccbf4f57b2a93fd7e9c12cb1a188797c 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-emulation/mupen64-riceplugin
 # Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.10 2005/05/30 18:37:50 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.11 2005/09/20 15:26:50 mr_bones_ Exp $
+
+  20 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+  mupen64-riceplugin-5.1.0.ebuild:
+  remove gtk2 use flag
 
   30 May 2005; Sven Wegener <swegener@gentoo.org>
   mupen64-riceplugin-5.1.0.ebuild:
index 461fd8edb7d7713b21f095e71b7fd8e9e6a466c1..3b147380bd87350a6390730fa1ed6140b5dbff4f 100644 (file)
@@ -1,10 +1,8 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.8 2005/05/30 18:37:50 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.9 2005/09/20 15:26:50 mr_bones_ Exp $
 
-inherit games eutils libtool
-
-IUSE="gtk2"
+inherit eutils libtool games
 
 DESCRIPTION="an graphics plugin for mupen64"
 SRC_URI="http://mupen64.emulation64.com/files/0.4/riceplugin.tar.bz2"
@@ -13,55 +11,37 @@ HOMEPAGE="http://mupen64.emulation64.com/"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="x86"
+IUSE=""
 
 RDEPEND="sys-libs/zlib
-       !gtk2? ( =x11-libs/gtk+-1.2* )
-       gtk2? ( =x11-libs/gtk+-2* )
+       =x11-libs/gtk+-2*
        media-libs/libsdl
-       dev-lang/nasm
        virtual/glu
        virtual/opengl"
 
 DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
+       dev-lang/nasm"
 
 S="${WORKDIR}/riceplugin"
 
 src_unpack() {
        unpack ${A}
+       cd "${S}"
 
-       cd ${S}
-
-       epatch ${FILESDIR}/${PN}-makefile.patch || die "patch failed"
-
-       if use gtk2 ; then
-               epatch ${FILESDIR}/${PN}-gtk2.patch || die "patch failed"
-       fi
-
-       epatch ${FILESDIR}/${PN}-compile.patch || die "patch failed"
-       epatch ${FILESDIR}/${PN}-gcc4.patch || die "patch failed"
-
-       # the riceplugin requires sse support
-       #echo "#include <xmmintrin.h>" > ${T}/test.c
-       #$(gcc-getCC) ${CFLAGS} -o ${T}/test.s -S ${T}/test.c >&/dev/null || die
-       #"failed sse test"
-
+       epatch "${FILESDIR}"/${PN}-makefile.patch \
+               "${FILESDIR}"/${PN}-gtk2.patch \
+               "${FILESDIR}"/${PN}-compile.patch \
+               "${FILESDIR}"/${PN}-gcc4.patch
 }
 
 src_compile() {
-
        emake || die "emake failed"
-
 }
 
 src_install() {
-       local dir=${GAMES_LIBDIR}/mupen64
-       dodir ${dir}
-
-       exeinto ${dir}/plugins
+       exeinto "${GAMES_LIBDIR}"/mupen64/plugins
        doexe *.so
-       insinto ${dir}/plugins
+       insinto "${GAMES_LIBDIR}"/mupen64/plugins
        doins *.ini
-
        prepgamesdirs
 }
index 3328ece852db9bc7d00252bfb0e9c176d1e02dee..fd39865e57d2dff4e3aa374201e36f954f0ed0c8 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-emulation/mupen64
 # Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.16 2005/05/30 18:35:12 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/ChangeLog,v 1.17 2005/09/20 15:29:04 mr_bones_ Exp $
+
+  20 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+  mupen64-0.4-r2.ebuild:
+  remove gtk2 use flag
 
   30 May 2005; Sven Wegener <swegener@gentoo.org> mupen64-0.4-r2.ebuild:
   Removed unneeded use of gcc.eclass.
index b30deb0cc59352c9b1cbec391d4147dffdfead43..2310929eee00af27df00f552442014fa8b3eee9e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.4-r2.ebuild,v 1.5 2005/06/02 23:02:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64/mupen64-0.4-r2.ebuild,v 1.6 2005/09/20 15:29:04 mr_bones_ Exp $
 
 inherit eutils games
 
@@ -14,17 +14,16 @@ SRC_URI="http://mupen64.emulation64.com/files/${PV}/mupen64_src-${PV}.tar.bz2
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 x86"
-IUSE="asm avi gtk2"
+IUSE="asm avi"
 
 RDEPEND="sys-libs/zlib
        media-libs/libsdl
        virtual/glu
        virtual/opengl
        avi? ( media-video/avifile )
-       !gtk2? ( =x11-libs/gtk+-1.2* )
-       gtk2? ( =x11-libs/gtk+-2* )"
+       =x11-libs/gtk+-2*"
 DEPEND="${RDEPEND}
-       gtk2? ( dev-util/pkgconfig )"
+       dev-util/pkgconfig"
 RDEPEND="${RDEPEND}
        >=games-emulation/mupen64-glN64-0.4.1_rc2-r1"
 
@@ -34,12 +33,9 @@ src_unpack() {
        unpack ${A}
 
        cd "${S}"
-       epatch "${FILESDIR}/${PN}-makefiles.patch"
-       epatch "${FILESDIR}/${PN}-confdir.patch"
-       # gtk2 breaks some configuration dialogs (bug 56195 #35)
-       if use gtk2; then
-               epatch "${FILESDIR}/${PN}-gtk2-makefile.patch"
-       fi
+       epatch "${FILESDIR}/${PN}-makefiles.patch" \
+               "${FILESDIR}/${PN}-confdir.patch" \
+               "${FILESDIR}/${PN}-gtk2-makefile.patch"
        if use avi; then
                epatch "${FILESDIR}/${PN}-gentoo-avi.patch"
        fi
index 19fad8c87a66bf724eba5170e1faba1a95789e6d..17f12bea645808cdad179e5e51331c6762657736 100644 (file)
@@ -1,5 +1,5 @@
 MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 ad93f374d5160944b0c9c8519e5dd6b2 psemu-cdr-1.8.ebuild 1129
-MD5 a8b1e8bf3807af2bdbad58ee5ce23281 ChangeLog 1496
-MD5 169244f21e87968b8b24a2156c6ea257 files/1.8-makefile-cflags.patch 317
+MD5 3ec7ef39bc106d2d46adf5f5f6363521 psemu-cdr-1.8.ebuild 1003
+MD5 0a15d2abc3b3af4dffd04f5dfc8fd155 ChangeLog 1607
 MD5 cebe9fccfb101907d3a8588f1b5870c6 files/digest-psemu-cdr-1.8 58
+MD5 169244f21e87968b8b24a2156c6ea257 files/1.8-makefile-cflags.patch 317