dev-python/funcparserlib: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:42:56 +0000 (13:42 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:59:38 +0000 (13:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/funcparserlib/funcparserlib-0.3.6.ebuild [deleted file]

diff --git a/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild b/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild
deleted file mode 100644 (file)
index e69253e..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Recursive descent parsing library based on functional combinators"
-HOMEPAGE="https://pypi.org/project/funcparserlib/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
-       local m=unittest
-       cd "${BUILD_DIR}"/lib || die
-       "${PYTHON}" -m ${m} discover || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       local DOCS=( doc/*.md )
-       distutils-r1_python_install_all
-}