arm/ia64/s390/sh stable
authorMike Frysinger <vapier@gentoo.org>
Sun, 3 Dec 2006 03:10:54 +0000 (03:10 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sun, 3 Dec 2006 03:10:54 +0000 (03:10 +0000)
Package-Manager: portage-2.1.2_rc2-r3

dev-util/cmake/cmake-2.4.3.ebuild
dev-util/cscope/cscope-15.6.ebuild

index efe7adbe579644e5887b25e5cecca0f7505dc3cb..11f3afc30fa5d938f5f12fdccda5f17a02b70c5a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.3.ebuild,v 1.6 2006/12/01 12:36:12 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.4.3.ebuild,v 1.7 2006/12/03 03:08:49 vapier Exp $
 
 inherit toolchain-funcs eutils versionator
 
@@ -10,7 +10,7 @@ SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${P}.tar
 
 LICENSE="CMake"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm ~hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
 IUSE=""
 
 src_compile() {
index fbbee6ba04f3fa8ac3255d57ead4838298cd788e..3f9de2c80a7d2724a127cdc8400b66ac123810dd 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.6.ebuild,v 1.2 2006/11/29 16:54:51 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.6.ebuild,v 1.3 2006/12/03 03:10:54 vapier Exp $
 
-inherit gnuconfig elisp-common eutils
+inherit elisp-common eutils
 
 DESCRIPTION="Interactively examine a C program"
 HOMEPAGE="http://cscope.sourceforge.net/"
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
 
 LICENSE="as-is"
 SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha amd64 arm ~hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
 IUSE="emacs"
 
 RDEPEND=">=sys-libs/ncurses-5.2"
@@ -24,14 +24,13 @@ SITEFILE=50xcscope-gentoo.el
 
 src_compile() {
        STRIP="no"
-       gnuconfig_update
 
        econf || die
        make clean || die
        emake || die
 
        if use emacs ; then
-               cd ${S}/contrib/xcscope || die
+               cd "${S}"/contrib/xcscope || die
                elisp-compile *.el || die
        fi
 }