dev-python/ipaddr: Set DISTUTILS_USE_SETUPTOOLS, EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 13:59:14 +0000 (14:59 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 16 Dec 2019 14:37:35 +0000 (15:37 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/ipaddr/ipaddr-2.2.0.ebuild

index 2f58f9b96872aa48728f4a54beda0da9abfc4ed6..54a2b57f379c830ad2ee4cb9bd654ae2d3b9d1f8 100644 (file)
@@ -1,8 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=no
 PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
 
 inherit distutils-r1
@@ -15,8 +16,6 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 ~arm arm64 ~x86"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
 python_prepare() {
        if python_is_python3; then
                2to3 -n -w --no-diffs *.py || die