Cleanup the migration to for example actually install javadocs.
authorPetteri Räty <betelgeuse@gentoo.org>
Sun, 28 Jan 2007 21:10:38 +0000 (21:10 +0000)
committerPetteri Räty <betelgeuse@gentoo.org>
Sun, 28 Jan 2007 21:10:38 +0000 (21:10 +0000)
Package-Manager: portage-2.1.2-r4

dev-java/tagunit/ChangeLog
dev-java/tagunit/tagunit-1.0.1-r1.ebuild

index 8ddee44ab8b8b400f7b20268b098172da5e2561b..aa3ecacc6a58bb7b159e6611de205cc67ad40449 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for dev-java/tagunit
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/ChangeLog,v 1.10 2007/01/28 20:52:04 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/ChangeLog,v 1.11 2007/01/28 21:10:38 betelgeuse Exp $
+
+  28 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+  tagunit-1.0.1-r1.ebuild:
+  Cleanup the migration to for example actually install javadocs.
 
 *tagunit-1.0.1-r1 (28 Jan 2007)
 
index 4b9d2be68cfa10b4df9c3f958fcf9e8f66a3a88d..b9845d7e38991230cc1821c4c1fe35bcec039f03 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1-r1.ebuild,v 1.1 2007/01/28 20:52:04 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tagunit/tagunit-1.0.1-r1.ebuild,v 1.2 2007/01/28 21:10:38 betelgeuse Exp $
 
 inherit java-ant-2 java-pkg-2
 
@@ -26,24 +26,20 @@ S="${WORKDIR}/${P}-src/tagunit-core"
 
 src_unpack() {
        unpack ${A}
-       cd ${S}
+       cd "${S}"
 
        java-ant_rewrite-classpath
-}
-
-src_compile() {
        echo ${PV} > ../version.txt
        mkdir ../lib
-
-       local antflags="build"
-       antflags="${antflags} -Dgentoo.classpath=$(java-pkg_getjars ant-core,servletapi-2.4)"
-       eant ${antflags} $(use_doc javadoc)
 }
 
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="ant-core,servletapi-2.4"
+
 src_install() {
        java-pkg_dojar lib/${PN}.jar
        cd ${S}/..
-       dodoc changes.txt readme.txt
-       use doc && java-pkg_dohtml -r doc/api/*
+       dodoc changes.txt readme.txt || die
+       use doc && java-pkg_dojavadoc tagunit-core/doc/api
        use source && java-pkg_dosrc tagunit-core/src/*
 }