dev-libs/librelp: Drop old versions for cleanup
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 26 Feb 2017 13:56:34 +0000 (14:56 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 26 Feb 2017 14:10:56 +0000 (15:10 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-libs/librelp/Manifest
dev-libs/librelp/files/librelp-1.2.7-prevent-segfault-with-keepalive.patch [deleted file]
dev-libs/librelp/librelp-1.2.10.ebuild [deleted file]
dev-libs/librelp/librelp-1.2.7-r1.ebuild [deleted file]

index 9ff74e1e1ba1f46974bfad2540d4825bc6d4f335..e8395147e0e9dc181c177c3b1818c9614570d95c 100644 (file)
@@ -1,3 +1 @@
-DIST librelp-1.2.10.tar.gz 415653 SHA256 6c80eed5e29061d2cce35408ae43ddaee354edc27c1076eabec6da4eaecdcc72 SHA512 09f88daa59711449a50b9414f30bc7a217bf3dd7722af53caee024bfe1060e1749f1083d2965c79cbe3c12819359cd3cc262e9dea8ab5ad7bf275f3b61ca907f WHIRLPOOL fd9ec0af4769df65d9631faf0b5739f10b50d55b7ba60bb42f4a41a46bc1e1cf7fbda58b2c3b1fd1f0f7fff3d41ffc0c9cd52d243a599be033c2a5e118db8ca1
 DIST librelp-1.2.12.tar.gz 437945 SHA256 0355730524f7b20bed1b85697296b6ce57ac593ddc8dddcdca263da71dee7bd7 SHA512 bfc38882404e06c047bdabd203d71beba67bc5a717d2d6733863f15f0a3a09b4a792a628a1653c102c828fde7ff67cc8ade637de785399ab48a68605b23a72ed WHIRLPOOL 0d3193b3f0f21e940793df0f2c53bb46944c1fbfe4f7aee8b0ecbaead3053185f981a695eaae65d6ea1581ea4a8011e83e2ffff0436ab15bdd4f82b9a012f9a3
-DIST librelp-1.2.7.tar.gz 410896 SHA256 3a434a1c71772706104cfb1c93ba8e6809d257851d60de29ac2142c60c68d7d1 SHA512 f8a71ad037cb5eaeb807b1bcb942893e2d10bcd57b18764bb13700c8e114d59de37b1b36560288abac18a07b6cb2920b46feaef4ae629aa0b3478ed16723542a WHIRLPOOL 784f291d0318b29be33bcd4bdd41e04c2e0fc8f292c6cb7f5985743559aa65f3c10932680f943e065ebf34e3f62c75bf2ed5500aebe0b7ab2fa7e64ced37cc44
diff --git a/dev-libs/librelp/files/librelp-1.2.7-prevent-segfault-with-keepalive.patch b/dev-libs/librelp/files/librelp-1.2.7-prevent-segfault-with-keepalive.patch
deleted file mode 100644 (file)
index 2f9803d..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 0ca7f807958e8365b2fd2f3fd833814c83594bdc Mon Sep 17 00:00:00 2001
-From: Tomas Heinrich <theinric@redhat.com>
-Date: Sun, 1 Jun 2014 16:44:59 +0200
-Subject: [PATCH] Reorder code, prevent access of uninitialized data
-
----
- src/tcp.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/tcp.c b/src/tcp.c
-index 1e0fd11..e21db51 100644
---- a/src/tcp.c
-+++ b/src/tcp.c
-@@ -713,12 +713,12 @@ relpTcpAcceptConnReq(relpTcp_t **ppThis, int sock, relpSrv_t *pSrv)
-               ABORT_FINALIZE(RELP_RET_ACCEPT_ERR);
-       }
--      if(pSrv->bKeepAlive)
--              EnableKeepAlive(pThis, pSrv, iNewSock);
--
-       /* construct our object so that we can use it... */
-       CHKRet(relpTcpConstruct(&pThis, pEngine, RELP_SRV_CONN, pSrv));
-+      if(pSrv->bKeepAlive)
-+              EnableKeepAlive(pThis, pSrv, iNewSock);
-+
-       /* TODO: obtain hostname, normalize (callback?), save it */
-       CHKRet(relpTcpSetRemHost(pThis, (struct sockaddr*) &addr));
-       pThis->pEngine->dbgprint("remote host is '%s', ip '%s'\n", pThis->pRemHostName, pThis->pRemHostIP);
--- 
-1.9.3
-
diff --git a/dev-libs/librelp/librelp-1.2.10.ebuild b/dev-libs/librelp/librelp-1.2.10.ebuild
deleted file mode 100644 (file)
index 6acb0c7..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="An easy to use library for the RELP protocol"
-HOMEPAGE="http://www.librelp.com/"
-SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3+ doc? ( FDL-1.3 )"
-
-# subslot = soname version
-SLOT="0/0.1.0"
-
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86"
-IUSE="debug doc +ssl static-libs"
-
-RDEPEND="
-       ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
-"
-
-DEPEND="
-       ssl? ( >=net-libs/gnutls-3.3.17.1:0= )
-       virtual/pkgconfig
-"
-
-src_prepare() {
-       sed -i \
-               -e 's/ -g"/"/g' \
-               configure.ac || die "sed failed"
-
-       default
-
-       eautoreconf
-}
-
-src_configure() {
-       local myeconfargs=(
-               $(use_enable debug)
-               $(use_enable ssl tls)
-               $(use_enable static-libs static)
-       )
-
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       local DOCS=( ChangeLog )
-       use doc && local HTML_DOCS=( doc/relp.html )
-       default
-
-       find "${ED}"usr/lib* -name '*.la' -delete || die
-}
diff --git a/dev-libs/librelp/librelp-1.2.7-r1.ebuild b/dev-libs/librelp/librelp-1.2.7-r1.ebuild
deleted file mode 100644 (file)
index 497f4c9..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools-utils
-
-DESCRIPTION="An easy to use library for the RELP protocol"
-HOMEPAGE="http://www.librelp.com/"
-SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3+ doc? ( FDL-1.3 )"
-SLOT="0"
-KEYWORDS="amd64 ~arm hppa ~sparc x86"
-IUSE="debug doc +ssl static-libs"
-
-RDEPEND="
-       ssl? ( >=net-libs/gnutls-2.12.23-r1 )
-"
-
-DEPEND="
-       >=net-libs/gnutls-2.12.23-r1
-       virtual/pkgconfig
-"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-PATCHES=( "${FILESDIR}/${P}-prevent-segfault-with-keepalive.patch" )
-
-src_configure() {
-       # gnutls-headers are always required (in src/tcp.h) despite the flag, bug #513754
-       local myeconfargs=(
-               $(use_enable debug)
-               $(use_enable ssl tls)
-       )
-
-       autotools-utils_src_configure
-}
-
-src_install() {
-       use doc && HTML_DOCS=( doc/relp.html )
-       autotools-utils_src_install
-}