app-emulation/flannel: Remove old version 0.10.0
authorZac Medico <zmedico@gentoo.org>
Thu, 19 Sep 2019 00:00:17 +0000 (17:00 -0700)
committerZac Medico <zmedico@gentoo.org>
Thu, 19 Sep 2019 00:00:54 +0000 (17:00 -0700)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-emulation/flannel/Manifest
app-emulation/flannel/flannel-0.10.0.ebuild [deleted file]

index 3c733a58ce162bcd14f6474e2cf2eaa0e9ab5b32..236b7994970b60571ac38e89eb219e33ba8b4bc2 100644 (file)
@@ -1,2 +1 @@
-DIST flannel-0.10.0.tar.gz 4799262 BLAKE2B 7341f34f72bf2d51aa727d03eb94f376fd9da825dea1865db9d0b46d5bcc0338569b8aa81c3442b101768cd7b58bef3957bea86a38e8c1cca921b7a03d1b2bf3 SHA512 b71fff80f7c4891279e82c6c430cdbff1eb3966cc4817d1c2c5ed7a731e9466f04e51532734244510ab47cba07557c052fbaa9a4a9ecced56fa1e37f6681b1c9
 DIST flannel-0.11.0.tar.gz 6443391 BLAKE2B 5358e513a73fec6d8fcdb0182ec814fcf204eb12830f7d60acb3d4432f821ccc9e174fcc7adb57584ab1782c3f285e46b51bb0f76635fab9cf851cb2bd40c1b3 SHA512 72d18cd4ec58ede3848da3b94b7f3e33f8dda59d9fceb13864757998a24f0b312bc5b5d7927d3da8a805475efee469095ac09390fa632eb0c6ef9dd0f5d38a3b
diff --git a/app-emulation/flannel/flannel-0.10.0.ebuild b/app-emulation/flannel/flannel-0.10.0.ebuild
deleted file mode 100644 (file)
index 3fd3628..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit golang-vcs-snapshot systemd user
-
-KEYWORDS="~amd64"
-DESCRIPTION="An etcd backed network fabric for containers"
-EGO_PN="github.com/coreos/flannel"
-HOMEPAGE="https://github.com/coreos/flannel"
-SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="hardened"
-RESTRICT="test"
-
-src_prepare() {
-       default
-       sed -e "s:^var Version =.*:var Version = \"${PV}\":" \
-               -i "${S}/src/${EGO_PN}/version/version.go" || die
-}
-
-src_compile() {
-       CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')"\
-       GOPATH="${WORKDIR}/${P}" \
-               go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
-       [[ -x bin/${PN} ]] || die
-}
-
-src_test() {
-       GOPATH="${WORKDIR}/${P}" \
-               go test -v -work -x "${EGO_PN}" || die
-}
-
-src_install() {
-       newbin "bin/${PN}" ${PN}d
-       cd "src/${EGO_PN}" || die
-       exeinto /usr/libexec/flannel
-       doexe dist/mk-docker-opts.sh
-       insinto /etc/systemd/system/docker.service.d
-       newins "${FILESDIR}/flannel-docker.conf" flannel.conf
-       newinitd "${FILESDIR}"/flanneld.initd flanneld
-       newconfd "${FILESDIR}"/flanneld.confd flanneld
-       keepdir /var/log/${PN}
-       insinto /etc/logrotate.d
-       newins "${FILESDIR}"/flanneld.logrotated flanneld
-       systemd_newtmpfilesd "${FILESDIR}/flannel.tmpfilesd" flannel.conf
-       systemd_dounit "${FILESDIR}/flanneld.service"
-       dodoc README.md
-}