Remove hardmasked packages
authorPacho Ramos <pacho@gentoo.org>
Wed, 19 Jul 2017 08:21:46 +0000 (10:21 +0200)
committerPacho Ramos <pacho@gentoo.org>
Wed, 19 Jul 2017 08:21:46 +0000 (10:21 +0200)
16 files changed:
media-sound/gejengel/Manifest [deleted file]
media-sound/gejengel/files/0.1.4-flac_ln.patch [deleted file]
media-sound/gejengel/files/bckport-debug.patch [deleted file]
media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch [deleted file]
media-sound/gejengel/files/gejengel-0.1.4-ffmpeg.patch [deleted file]
media-sound/gejengel/files/gejengel-0.1.4-ffmpeg2.patch [deleted file]
media-sound/gejengel/files/gejengel-0.1.4-libav9.patch [deleted file]
media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch [deleted file]
media-sound/gejengel/gejengel-0.1.4-r2.ebuild [deleted file]
media-sound/gejengel/gejengel-0.1.4-r3.ebuild [deleted file]
media-sound/gejengel/metadata.xml [deleted file]
net-voip/homer/Manifest [deleted file]
net-voip/homer/homer-0.25-r1.ebuild [deleted file]
net-voip/homer/homer-9999.ebuild [deleted file]
net-voip/homer/metadata.xml [deleted file]
profiles/package.mask

diff --git a/media-sound/gejengel/Manifest b/media-sound/gejengel/Manifest
deleted file mode 100644 (file)
index 1c405a2..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST gejengel-0.1.4.tar.gz 473674 SHA256 036a4ff2520b6ff9f73fc3012d8810939583f0dc25be6bac28689dffb6e9023b SHA512 584a6250ec87475babbeff86c7f2427cf731b3ec0906dcc6219bf40cf1c5533feaf3f076d0f34daeaa21a1c2596e5fe53e4530820a6d47dbca7f9afd6f489580 WHIRLPOOL 0afd7138782f6337bf7aa770ae8dbddf3d037978ffabf6b7f9c5fedddd6e1a3354714d9d80e7414c27b8250be8f41d7476454f2c1408b8709d063e61774d316f
diff --git a/media-sound/gejengel/files/0.1.4-flac_ln.patch b/media-sound/gejengel/files/0.1.4-flac_ln.patch
deleted file mode 100644 (file)
index 2d4473e..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-Fixes Bug #542708
-The code uses functionality provided by libFLAC and libFLAC++ but only linked against libFLAC++.
-Included also is a check for libFLAC availability and added linking against libFLAC
---- a/gejengel-0.1.4/configure.ac
-+++ b/gejengel-0.1.4/configure.ac
-@@ -129,14 +129,20 @@ AC_ARG_ENABLE(flac,
-     [ enable_flac=$enableval ] )
- if test "$enable_flac" != "no"; then
--    PKG_CHECK_MODULES(FLAC, flac++, HAVE_FLAC=yes, HAVE_FLAC=no)
-+    PKG_CHECK_MODULES(FLAC, flac, HAVE_FLAC=yes, HAVE_FLAC=no)
-     if test $HAVE_FLAC = yes; then
--        AC_DEFINE(HAVE_FLAC, [1], Flac support enabled)
--        AC_SUBST(FLAC_CFLAGS)
--        AC_SUBST(FLAC_LIBS)
-+      AC_DEFINE(HAVE_FLAC, [1], Flac found)
-+      AC_SUBST(FLAC_CFLAGS)
-+      AC_SUBST(FLAC_LIBS)
-+        PKG_CHECK_MODULES(FLACPP, flac++, HAVE_FLACPP=yes, HAVE_FLACPP=no)
-+        if test $HAVE_FLACPP = yes; then
-+            AC_DEFINE(HAVE_FLACPP, [1], Flac support enabled)
-+            AC_SUBST(FLACPP_CFLAGS)
-+            AC_SUBST(FLACPP_LIBS)
-+        fi
-     fi
- fi
--AM_CONDITIONAL(FLAC, test "$HAVE_FLAC" = "yes")
-+AM_CONDITIONAL(FLAC, test "$HAVE_FLACPP" = "yes")
- ########################################################################
- # Mad
---- a/gejengel-0.1.4/Makefile.am
-+++ b/gejengel-0.1.4/Makefile.am
-@@ -256,7 +256,7 @@ libgejengel_la_LIBADD = libutils.la \
-                         libmusiclibrary.la \
-                         libcore.la \
-                         libplugins.la -lpthread \
--                        $(FFMPEG_LIBS) $(ALSA_LIBS) $(OPENAL_LIBS) $(GLIBMM_LIBS) $(SQLITE3_LIBS) $(TAGLIB_LIBS) $(LASTFM_LIBS) $(LIBNOTIFY_LIBS) $(PULSE_LIBS) $(IMAGEMAGICK_LIBS) $(GSTREAMER_LIBS) $(FLAC_LIBS) $(MAD_LIBS) $(DBUS_LIBS) $(XDGBASEDIR_LIBS)
-+                        $(FFMPEG_LIBS) $(ALSA_LIBS) $(OPENAL_LIBS) $(GLIBMM_LIBS) $(SQLITE3_LIBS) $(TAGLIB_LIBS) $(LASTFM_LIBS) $(LIBNOTIFY_LIBS) $(PULSE_LIBS) $(IMAGEMAGICK_LIBS) $(GSTREAMER_LIBS) $(FLACPP_LIBS) $(FLAC_LIBS) $(MAD_LIBS) $(DBUS_LIBS) $(XDGBASEDIR_LIBS)
- bin_PROGRAMS = gejengel
diff --git a/media-sound/gejengel/files/bckport-debug.patch b/media-sound/gejengel/files/bckport-debug.patch
deleted file mode 100644 (file)
index 76e42be..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/AudioDecoder/ffmpegdecoder.cpp.orig
-+++ src/AudioDecoder/ffmpegdecoder.cpp
-@@ -98,7 +98,11 @@ void FFmpegDecoder::initialise()
-     }
- #ifdef ENABLE_DEBUG
-+#if LIBAVCODEC_VERSION_MAJOR < 53
-     dump_format(m_pFormatContext, 0, m_Filepath.c_str(), false);
-+#else
-+    av_dump_format(m_pFormatContext, 0, m_Filepath.c_str(), false);
-+#endif
- #endif
-     initializeAudio();
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch
deleted file mode 100644 (file)
index 10d43d3..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-Index: gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
-===================================================================
---- gejengel-0.1.4.orig/src/AudioDecoder/ffmpegdecoder.cpp
-+++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
-@@ -83,7 +83,7 @@ void FFmpegDecoder::initialise()
-     avcodec_register_all();
-     av_register_all();
--    if (av_open_input_file(&m_pFormatContext, m_Filepath.c_str(), NULL, 0, NULL) != 0)
-+    if (avformat_open_input(&m_pFormatContext, m_Filepath.c_str(), NULL, NULL) != 0)
-     {
-         throw logic_error("Could not open input file: " + m_Filepath);
-     }
-@@ -307,21 +307,7 @@ AudioFormat FFmpegDecoder::getAudioForma
- {
-     AudioFormat format;
--    switch(m_pAudioCodecContext->sample_fmt)
--    {
--    case SAMPLE_FMT_U8:
--        format.bits = 8;
--        break;
--    case SAMPLE_FMT_S16:
--        format.bits = 16;
--        break;
--    case SAMPLE_FMT_S32:
--        format.bits = 32;
--        break;
--    default:
--        format.bits = 0;
--    }
--
-+    format.bits             = av_get_bytes_per_sample(m_pAudioCodecContext->sample_fmt) << 3;
-     format.rate             = m_pAudioCodecContext->sample_rate;
-     format.numChannels      = m_pAudioCodecContext->channels;
-     format.framesPerPacket  = m_pAudioCodecContext->frame_size;
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg.patch b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg.patch
deleted file mode 100644 (file)
index 658ff0c..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
-===================================================================
---- gejengel-0.1.4.orig/src/AudioDecoder/ffmpegdecoder.cpp
-+++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
-@@ -104,7 +104,7 @@ void FFmpegDecoder::initializeAudio()
- {
-     for(uint32_t i = 0; i < m_pFormatContext->nb_streams; ++i)
-     {
--        if (m_pFormatContext->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO)
-+        if (m_pFormatContext->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO)
-         {
-             m_pAudioStream = m_pFormatContext->streams[i];
-             m_AudioStream = i;
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg2.patch b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg2.patch
deleted file mode 100644 (file)
index b6850eb..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
-===================================================================
---- gejengel-0.1.4.orig/src/AudioDecoder/ffmpegdecoder.cpp
-+++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
-@@ -28,6 +28,10 @@ extern "C"
-     #include <libavcodec/avcodec.h>
- }
-+#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
-+#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
-+#endif
-+
- using namespace std;
- using namespace utils;
-@@ -71,7 +75,7 @@ void FFmpegDecoder::destroy()
-     if (m_pFormatContext)
-     {
--        av_close_input_file(m_pFormatContext);
-+        avformat_close_input(&m_pFormatContext);
-         m_pFormatContext = NULL;
-     }
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-libav9.patch b/media-sound/gejengel/files/gejengel-0.1.4-libav9.patch
deleted file mode 100644 (file)
index 5529fb7..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -urN gejengel-0.1.4.old/src/AudioDecoder/ffmpegdecoder.cpp gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
---- gejengel-0.1.4.old/src/AudioDecoder/ffmpegdecoder.cpp      2013-06-22 18:48:46.176890946 +0200
-+++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp  2013-06-22 18:50:04.516888158 +0200
-@@ -88,7 +88,7 @@
-         throw logic_error("Could not open input file: " + m_Filepath);
-     }
--    if (av_find_stream_info(m_pFormatContext) < 0)
-+    if (avformat_find_stream_info(m_pFormatContext, NULL) < 0)
-     {
-         throw logic_error("Could not find stream information in " + m_Filepath);
-     }
-@@ -134,7 +134,7 @@
-     m_pFormatContext->flags |= AVFMT_FLAG_GENPTS;
-     m_pFormatContext->streams[m_AudioStream]->discard = AVDISCARD_DEFAULT;
--    if (avcodec_open(m_pAudioCodecContext, m_pAudioCodec) < 0)
-+    if (avcodec_open2(m_pAudioCodecContext, m_pAudioCodec, NULL) < 0)
-     {
-         throw logic_error("Could not open audio codec for " + m_Filepath);
-     }
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch b/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch
deleted file mode 100644 (file)
index 8026d89..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/Plugins/notificationplugin.cpp
-+++ src/Plugins/notificationplugin.cpp
-@@ -33,6 +33,10 @@
- #include "ui/sharedfunctions.h"
- #include "MusicLibrary/album.h"
-+#ifndef NOTIFY_CHECK_VERSION
-+#define NOTIFY_CHECK_VERSION(x,y,z) 0
-+#endif
-+
- using namespace std;
- using namespace Gtk;
-@@ -85,7 +89,12 @@
-         }
-     }
-+#if NOTIFY_CHECK_VERSION (0, 7, 0)
-+    m_pNotification = notify_notification_new("dummy", "", NULL);
-+#else
-     m_pNotification = notify_notification_new("dummy", "", NULL, NULL);
-+#endif
-+
-     notify_notification_set_timeout (m_pNotification, NOTIFY_EXPIRES_DEFAULT);
-     notify_notification_set_urgency (m_pNotification, NOTIFY_URGENCY_NORMAL);
diff --git a/media-sound/gejengel/gejengel-0.1.4-r2.ebuild b/media-sound/gejengel/gejengel-0.1.4-r2.ebuild
deleted file mode 100644 (file)
index 0a2823d..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils multilib flag-o-matic
-
-DESCRIPTION="Lightweight audio player"
-HOMEPAGE="https://github.com/dirkvdb/gejengel"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+alsa audioscrobbler debug dbus +ffmpeg flac libnotify mad openal pulseaudio syslog"
-
-RDEPEND="dev-cpp/gtkmm:2.4
-       dev-cpp/pangomm:1.4
-       media-libs/taglib
-       dev-db/sqlite:3
-       media-gfx/imagemagick[cxx]
-       mad? ( media-libs/libmad )
-       flac? ( media-libs/flac[cxx] )
-       ffmpeg? ( >=virtual/ffmpeg-9 )
-       audioscrobbler? ( >=media-libs/lastfmlib-0.4 )
-       dbus? ( dev-libs/dbus-glib )
-       libnotify? ( x11-libs/libnotify )
-       openal? ( media-libs/openal )
-       alsa? ( media-libs/alsa-lib )
-       pulseaudio? ( media-sound/pulseaudio )"
-DEPEND="${RDEPEND}
-       dev-libs/libxdg-basedir
-       dev-util/intltool
-       >=sys-devel/automake-1.11"
-
-DOCS=( AUTHORS ChangeLog README TODO )
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-libnotify-0.7.patch \
-               "${FILESDIR}"/${P}-ffmpeg.patch \
-               "${FILESDIR}"/${P}-ffmpeg-1.patch \
-               "${FILESDIR}"/${P}-libav9.patch \
-               "${FILESDIR}"/${P}-ffmpeg2.patch
-       # Remove Vesion and Encoding from the desktop file
-       sed -i -e "/Version/d" -e "/Encoding/d" \
-               data/${PN}.desktop.in || die "sed failed"
-       append-cxxflags "-D__STDC_CONSTANT_MACROS"
-}
-
-src_configure() {
-       econf \
-               --disable-shared \
-               $(use_enable syslog logging) \
-               $(use_enable debug) \
-               $(use_enable openal) \
-               $(use_enable audioscrobbler lastfm) \
-               $(use_enable dbus) \
-               $(use_enable libnotify) \
-               $(use_enable mad) \
-               $(use_enable flac) \
-               $(use_enable ffmpeg) \
-               $(use_enable alsa) \
-               $(use_enable pulseaudio) \
-               --disable-unittests
-}
-
-src_compile() {
-       emake CXXFLAGS="${CXXFLAGS}"
-}
-
-src_install() {
-       default
-       # The libgejengel.a is used by the package when building but shouldn't end
-       # up in the installation target
-       rm -f "${ED}"usr/$(get_libdir)/libgejengel.{a,la}
-}
diff --git a/media-sound/gejengel/gejengel-0.1.4-r3.ebuild b/media-sound/gejengel/gejengel-0.1.4-r3.ebuild
deleted file mode 100644 (file)
index 9137750..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils multilib flag-o-matic
-
-DESCRIPTION="Lightweight audio player"
-HOMEPAGE="https://github.com/dirkvdb/gejengel"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+alsa audioscrobbler debug dbus +ffmpeg flac libnotify mad openal pulseaudio syslog"
-
-RDEPEND="dev-cpp/gtkmm:2.4
-       dev-cpp/pangomm:1.4
-       media-libs/taglib
-       dev-db/sqlite:3
-       media-gfx/imagemagick:=[cxx]
-       mad? ( media-libs/libmad )
-       flac? ( media-libs/flac[cxx] )
-       ffmpeg? ( >=virtual/ffmpeg-9 )
-       audioscrobbler? ( >=media-libs/lastfmlib-0.4 )
-       dbus? ( dev-libs/dbus-glib )
-       libnotify? ( x11-libs/libnotify )
-       openal? ( media-libs/openal )
-       alsa? ( media-libs/alsa-lib )
-       pulseaudio? ( media-sound/pulseaudio )"
-DEPEND="${RDEPEND}
-       dev-libs/libxdg-basedir
-       dev-util/intltool
-       >=sys-devel/automake-1.11"
-
-DOCS=( AUTHORS ChangeLog README TODO )
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-libnotify-0.7.patch \
-               "${FILESDIR}"/${P}-ffmpeg.patch \
-               "${FILESDIR}"/${P}-ffmpeg-1.patch \
-               "${FILESDIR}"/${P}-libav9.patch \
-               "${FILESDIR}"/${P}-ffmpeg2.patch \
-               "${FILESDIR}"/${PV}-flac_ln.patch \
-               "${FILESDIR}"/bckport-debug.patch
-
-       # Remove Vesion and Encoding from the desktop file
-       sed -i -e "/Version/d" -e "/Encoding/d" \
-               data/${PN}.desktop.in || die "sed failed"
-       append-cxxflags "-D__STDC_CONSTANT_MACROS"
-
-       eautoreconf
-}
-
-src_configure() {
-       append-cxxflags -std=c++11
-       econf \
-               --disable-shared \
-               $(use_enable syslog logging) \
-               $(use_enable debug) \
-               $(use_enable openal) \
-               $(use_enable audioscrobbler lastfm) \
-               $(use_enable dbus) \
-               $(use_enable libnotify) \
-               $(use_enable mad) \
-               $(use_enable flac) \
-               $(use_enable ffmpeg) \
-               $(use_enable alsa) \
-               $(use_enable pulseaudio) \
-               --disable-unittests
-}
-
-src_compile() {
-       emake CXXFLAGS="${CXXFLAGS}"
-}
-
-src_install() {
-       default
-       # The libgejengel.a is used by the package when building but shouldn't end
-       # up in the installation target
-       rm -f "${ED}"usr/$(get_libdir)/libgejengel.{a,la}
-}
diff --git a/media-sound/gejengel/metadata.xml b/media-sound/gejengel/metadata.xml
deleted file mode 100644 (file)
index 9cd7ca8..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <!-- maintainer-needed -->
-       <use>
-               <flag name="audioscrobbler">Enable track submission on last.fm</flag>
-       </use>
-       <longdescription lang="en">
-       </longdescription>
-       <upstream>
-               <remote-id type="google-code">gejengel</remote-id>
-               <remote-id type="github">dirkvdb/gejengel</remote-id>
-       </upstream>
-</pkgmetadata>
diff --git a/net-voip/homer/Manifest b/net-voip/homer/Manifest
deleted file mode 100644 (file)
index 225f21c..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST homer-0.25-ffmpeg2.patch 65617 SHA256 ce1327a59dc20c2fbe23e968786ecce21126cdb2119916bf2227594dc8c0a229 SHA512 fb4ca0bd161c94999b54b86337220f3f018672e4a5031788d8292273515fe68d4364574645d96e04b19bdb64f1b032119503cf823c7604d625015ba0cdabf030 WHIRLPOOL 909069e830b9ef473a006f686a5e5e9f7279c5b0fc8fb8f212a30b767106055970441fa4fdbe2d443fce500024bc00494c112ebb3b95a65a475b2731e8d361c7
-DIST homer-0.25.tar.gz 1404242 SHA256 1c3e67a7f7134a317bc32dfb691679a2997fbfa129c70d5d165ccfd0272a752d SHA512 92254f9cc133589760a4c3081e1636232ace8eb972f7800c4fb5aaeba52e22546c6772e4c93625aa31a5d7b366f441cf8155f52d85ca44dade60edebf98b6340 WHIRLPOOL 944277b8248a1037dd27881456b6fb304d19d2f12cc7bc4268ba3dbf876de668fde25749dfbfd424950fe641d7dc65f5f14a29e9d14d5c1e738dc555af201ffe
diff --git a/net-voip/homer/homer-0.25-r1.ebuild b/net-voip/homer/homer-0.25-r1.ebuild
deleted file mode 100644 (file)
index 11c9fa9..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Homer Conferencing (short: Homer) is a free SIP softphone with advanced audio and video support"
-HOMEPAGE="http://www.homer-conferencing.com"
-
-MY_PN="Homer-Conferencing"
-MY_BIN="Homer"
-
-if [[ ${PV} == *9999* ]]; then
-       inherit git-2
-       EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git"
-       KEYWORDS=""
-else
-       SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/V${PV}.tar.gz -> ${PN}-${PV}.tar.gz
-       https://dev.gentoo.org/~hwoarang/distfiles/${P}-ffmpeg2.patch"
-       KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="pulseaudio"
-
-DEPEND="dev-util/cmake
-       >=dev-libs/openssl-1.0
-       media-libs/alsa-lib
-       media-libs/libsdl[X,sound,video,alsa]
-       media-libs/portaudio[alsa]
-       media-libs/sdl-mixer
-       media-libs/sdl-sound
-       media-libs/x264:*
-       media-video/ffmpeg:0[X]
-       net-libs/sofia-sip
-       dev-qt/qtcore:4
-       dev-qt/qtdbus:4
-       dev-qt/qtgui:4
-       dev-qt/qtmultimedia:4
-       dev-qt/qtwebkit:4
-       pulseaudio? ( media-sound/pulseaudio )"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_prepare() {
-       epatch "${DISTDIR}/${P}-ffmpeg2.patch"
-       # Bug #543138
-       sed -e '/mRtpEncoderStream->reference_dts = 0;/d' \
-               -i HomerMultimedia/src/RTP.cpp || die
-
-       if use pulseaudio; then
-               sed -i \
-                       -e "/^set(FEATURE_PULSEAUDIO/s:OFF:ON:" \
-                       HomerBuild/config/HomerFeatures.txt || die "sed failed"
-       fi
-}
-
-src_compile() {
-       tc-export CXX
-       emake -C HomerBuild default \
-               INSTALL_PREFIX=/usr/bin \
-               INSTALL_LIBDIR=/usr/$(get_libdir) \
-               INSTALL_DATADIR=/usr/share/${PN} \
-               VERBOSE=1
-}
-
-src_install() {
-       emake -C HomerBuild install \
-               DESTDIR="${D}" \
-               VERBOSE=1
-
-       # Create .desktop entry
-       doicon ${MY_BIN}/${MY_BIN}.png
-       make_desktop_entry "${MY_BIN}" "${MY_PN}" "${MY_BIN}" "Network;InstantMessaging;Telephony;VideoConference"
-}
diff --git a/net-voip/homer/homer-9999.ebuild b/net-voip/homer/homer-9999.ebuild
deleted file mode 100644 (file)
index 4d876c0..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Homer Conferencing (short: Homer) is a free SIP softphone with advanced audio and video support"
-HOMEPAGE="http://www.homer-conferencing.com"
-
-MY_PN="Homer-Conferencing"
-MY_BIN="Homer"
-
-if [[ ${PV} == *9999* ]]; then
-       inherit git-2
-       EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git"
-       KEYWORDS=""
-else
-       SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/V${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="pulseaudio"
-
-DEPEND=">=dev-libs/openssl-1.0
-       media-libs/alsa-lib
-       media-libs/libsdl[X,sound,video,alsa]
-       media-libs/portaudio[alsa]
-       media-libs/sdl-mixer
-       media-libs/sdl-sound
-       media-libs/x264:*
-       media-video/ffmpeg:0[X]
-       net-libs/sofia-sip
-       dev-qt/qtcore:4
-       dev-qt/qtdbus:4
-       dev-qt/qtgui:4
-       dev-qt/qtmultimedia:4
-       dev-qt/qtwebkit:4
-       pulseaudio? ( media-sound/pulseaudio )"
-
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_prepare() {
-       if use pulseaudio; then
-               sed -i \
-                       -e "/^set(FEATURE_PULSEAUDIO/s:OFF:ON:" \
-                       HomerBuild/config/HomerFeatures.txt || die "sed failed"
-       fi
-}
-
-src_compile() {
-       tc-export CXX
-       emake -C HomerBuild default \
-               INSTALL_PREFIX=/usr/bin \
-               INSTALL_LIBDIR=/usr/$(get_libdir) \
-               INSTALL_DATADIR=/usr/share/${PN} \
-               VERBOSE=1
-}
-
-src_install() {
-       emake -C HomerBuild install \
-               DESTDIR="${D}" \
-               VERBOSE=1
-
-       # Create .desktop entry
-       doicon ${MY_BIN}/${MY_BIN}.png
-       make_desktop_entry "${MY_BIN}" "${MY_PN}" "${MY_BIN}" "Network;InstantMessaging;Telephony;VideoConference"
-}
diff --git a/net-voip/homer/metadata.xml b/net-voip/homer/metadata.xml
deleted file mode 100644 (file)
index fc91a16..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="person">
-               <email>gentoo@pennewiss.de</email>
-               <name>Marcel Pennewiß</name>
-       </maintainer>
-       <maintainer type="project">
-               <email>proxy-maint@gentoo.org</email>
-               <name>Proxy Maintainers</name>
-       </maintainer>
-       <longdescription lang="en">
-</longdescription>
-       <upstream>
-               <remote-id type="github">Homer-Conferencing/Homer-Conferencing</remote-id>
-       </upstream>
-</pkgmetadata>
index 5dfae0770044a42be414b0a0bad2b9f6c2fbacf6..c6d7c563905f27a6733606ec0f97573f56fbced3 100644 (file)
@@ -416,16 +416,6 @@ app-emulation/vmware-player
 app-emulation/vmware-modules
 app-emulation/vmware-tools
 
-# Pacho Ramos <pacho@gentoo.org> (17 Jun 2017)
-# Not compatible with ffmpeg-3 (#589806) and needs vulnerable qtwebkit:4
-# (#620740). Removal in a month.
-net-voip/homer
-
-# Pacho Ramos <pacho@gentoo.org> (17 Jun 2017)
-# Dead for ages, relies on google-code for fetching, not compatible with
-# ffmpeg-3 neither with latest imagemagick (#575988). Removal in a month.
-media-sound/gejengel
-
 # Pawel Hajdan, Jr. <phajdan.jr@gentoo.org> (11 Jun 2017)
 # Dev channel releases are only for people who are developers or want more
 # experimental features and accept a more unstable release.