net-mail/email: drop old EAPI
authorAaron Bauman <bman@gentoo.org>
Sun, 3 Jun 2018 00:14:39 +0000 (20:14 -0400)
committerAaron Bauman <bman@gentoo.org>
Sun, 3 Jun 2018 02:58:44 +0000 (22:58 -0400)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

net-mail/email/Manifest
net-mail/email/email-2.5.0.ebuild [deleted file]
net-mail/email/email-3.0.5.ebuild [deleted file]
net-mail/email/email-3.1.2.ebuild [deleted file]

index 17ca2b05c9a38ec0a447670a413123846395de37..2b2aacedaab84d316a8c33cb9b21c534322902fc 100644 (file)
@@ -1,4 +1 @@
-DIST email-2.5.0.tar.bz2 133167 BLAKE2B 3c04076d20d84eaf098afac0ca214db6c3700e898e3f49cc1eaf0791904485504968cc442d4e81d9aa527786964423bb2e16894d005c848519ef07bbf106b05e SHA512 e1f56a875262db6dc79bd0e58e73875cc86bbc73c91c71fb44e9325e4d95b4133f32ca2f299e9bcdbb8217eb20ce155382f0c8d35c48f4d03caf88ef82193ad7
-DIST email-3.0.5.tar.bz2 176575 BLAKE2B 5981a3843bd58124584c7ab07c3d3ded6166fbd993e5a1415e28e0f73843c3b3f9776cfa9c57233002df7a516033060a6c7fae19c2d631b6c8a1cc294df95b45 SHA512 9cb664be7e23c7509d9091115b9ea5450bc90a78c16c3ac514cdff08a4d13f687c25ea5e10f9a644158e2f001c1022e03ba8d1994fcafa1605986c394f54621e
-DIST email-3.1.2.tar.bz2 179546 BLAKE2B 31bf4cb2c10d2ea3b668ebf7870edfc60683899bb7fbfb0b1bd4a126259307e88c0e385236961e34437637d5c8779b962d6ba8140bf2aecff1994cb1ff8026be SHA512 cd005a59b45985ec9ae3cfe86e989568732eaf1e2a127028d0faa7abc0e704ab59668c48b7249e8829fd4944ca8bb27fb3bd23bfe23df5f6fc861d1385f531d1
 DIST email-3.1.3.tar.bz2 178396 BLAKE2B 645d1fd3f0585ce6cbe2e0f2354989f07b39c83c8d21789a94d27a9e9820ea02ec1b213080018c560c7c79ef6f8fa2b636df4f40c9bc5390321d438cf64c448e SHA512 3fc1a8aa653a519261614e54b3215b89e41273207aa63f64572c8820093922a820ecad5e939b0eadf8d4c0587be83ffcb239bb31fd959b96dcf566157420f33b
diff --git a/net-mail/email/email-2.5.0.ebuild b/net-mail/email/email-2.5.0.ebuild
deleted file mode 100644 (file)
index 10ed37c..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-DESCRIPTION="Advanced CLI tool for sending email"
-HOMEPAGE="http://email.cleancode.org"
-SRC_URI="http://email.cleancode.org/download/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="alpha amd64 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_compile() {
-       local myconf=""
-
-       if [ -f /etc/conf.d/clock ]; then
-               . /etc/conf.d/clock
-               if [ x$CLOCK = "xUTC" ]; then
-                       elog "Using UTC timestamps (from /etc/conf.d/clock)"
-                       myconf="${myconf} --with-utc"
-               fi
-       fi
-
-       sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
-       sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
-
-       econf ${myconf} || die "econf failed"
-       emake || die "emake failed"
-}
-
-src_install() {
-       doman email.1
-       dodoc INSTALL quoted-printable.rfc RFC821 TODO
-       make DESTDIR="${D}" install || die "install failed"
-}
-
-pkg_preinst() {
-       rm "${D}"/usr/share/doc/"${P}"/email.1
-}
-
-pkg_postinst() {
-       echo
-       elog "Do not forget to edit /etc/email/email.conf file before using email."
-       echo
-}
diff --git a/net-mail/email/email-3.0.5.ebuild b/net-mail/email/email-3.0.5.ebuild
deleted file mode 100644 (file)
index 5f32151..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit flag-o-matic
-
-DESCRIPTION="Advanced CLI tool for sending email"
-HOMEPAGE="http://www.cleancode.org/projects/email"
-SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
-       append-ldflags $(no-as-needed)
-}
-
-src_compile() {
-       local myconf=""
-
-       if [ -f /etc/conf.d/clock ]; then
-               . /etc/conf.d/clock
-               if [ x$CLOCK = "xUTC" ]; then
-                       elog "Using UTC timestamps (from /etc/conf.d/clock)"
-                       myconf="${myconf} --with-utc"
-               fi
-       fi
-
-       sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
-       sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
-
-       econf ${myconf} || die "econf failed"
-       emake || die "emake failed"
-}
-
-src_install() {
-       doman email.1
-       dodoc INSTALL quoted-printable.rfc RFC821 TODO
-       make DESTDIR="${D}" install || die "install failed"
-}
-
-pkg_preinst() {
-       rm "${D}"/usr/share/doc/"${P}"/email.1
-}
-
-pkg_postinst() {
-       echo
-       elog "Do not forget to edit /etc/email/email.conf file before using email."
-       echo
-}
diff --git a/net-mail/email/email-3.1.2.ebuild b/net-mail/email/email-3.1.2.ebuild
deleted file mode 100644 (file)
index b8e28f5..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-DESCRIPTION="Advanced CLI tool for sending email"
-HOMEPAGE="http://www.cleancode.org/projects/email"
-SRC_URI="http://www.cleancode.org/downloads/${PN}/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-src_compile() {
-       local myconf=""
-
-       if [ -f /etc/conf.d/clock ]; then
-               . /etc/conf.d/clock
-               if [ x$CLOCK = "xUTC" ]; then
-                       elog "Using UTC timestamps (from /etc/conf.d/clock)"
-                       myconf="${myconf} --with-utc"
-               fi
-       fi
-
-       sed -i -e "s:/doc/email-\${version}:/share/doc:" configure
-       sed -i -e "s:DIVIDER = '---':DIVIDER = '-- ':" email.conf
-
-       econf ${myconf} || die "econf failed"
-       emake || die "emake failed"
-}
-
-src_install() {
-       doman email.1
-       dodoc INSTALL quoted-printable.rfc RFC821 TODO
-       make DESTDIR="${D}" install || die "install failed"
-}
-
-pkg_preinst() {
-       rm "${D}"/usr/share/doc/"${P}"/email.1
-}
-
-pkg_postinst() {
-       echo
-       elog "Do not forget to edit /etc/email/email.conf file before using email."
-       echo
-}