dev-libs/appstream: 0.12.11 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 13 May 2020 17:28:30 +0000 (19:28 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 13 May 2020 19:33:00 +0000 (21:33 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/appstream/Manifest
dev-libs/appstream/appstream-0.12.11.ebuild [new file with mode: 0644]

index 6f33fb2fb318e0326e7e23d667473a652945af41..2a846be931e2c44408f56123ecb111f890af4a9a 100644 (file)
@@ -1,2 +1,3 @@
 DIST AppStream-0.12.10.tar.xz 2045744 BLAKE2B fd8f96bd0b829e73bbbb5ae725feaf8f1275f2ed4a50ad107fddc52cdfd7d7c2e382235fc322513cdfe000789505e7b9998bb4e601e223d673ee65c0fbb55c25 SHA512 5cd7da7adbd035947bde6a6d7655dc2f7c1be25cef102e51ef88e8f684a83b196a41b440edaabdd89da69a9117a26dad30e548b86b50f324f0ba70eef95a6060
+DIST AppStream-0.12.11.tar.xz 2120548 BLAKE2B 6053d1d1bbe182c8e57f657ea5dda9c4a777d5a7955f39a57677502fbbe010d5c49a7872329d1ef716c41c7423bfb4d284e71af97f99ca6e466fbf369bf80272 SHA512 6000f4e9f995b2d481374db2409f212da9d48893c4a757cb7287e2731117f50d0ed284dedc0e24e505b3b7c9c9f38dd9a5f855eeb6c7445eb7203e74d4a5f790
 DIST AppStream-0.12.7.tar.xz 1958948 BLAKE2B 51a70395e4801ceeb3e97ac081f4c45be242cca14728f8efc5eec0d4b3cfa4cc9fab9ef7429c18e9bbb0dedb693a847258be1b11491155658a6ffa2a28358e35 SHA512 53ca7ebde3fcd345a895527da2ac5d829a09f25d28836a867b500282fba3465bde657cd75a4030cb831022f7a0d9f50aadb36078d62924e4d0edad6bfe3c5561
diff --git a/dev-libs/appstream/appstream-0.12.11.ebuild b/dev-libs/appstream/appstream-0.12.11.ebuild
new file mode 100644 (file)
index 0000000..4d3a31b
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ximion/${PN}"
+else
+       SRC_URI="https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+       S="${WORKDIR}/AppStream-${PV}"
+fi
+
+DESCRIPTION="Cross-distro effort for providing metadata for software in the Linux ecosystem"
+HOMEPAGE="https://www.freedesktop.org/wiki/Distributions/AppStream/"
+
+LICENSE="LGPL-2.1+ GPL-2+"
+# check as_api_level
+SLOT="0/4"
+IUSE="apt doc +introspection qt5 test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+       dev-libs/appstream-glib
+       dev-libs/libxslt
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       doc? ( app-text/docbook-xml-dtd:4.5 )
+       test? ( dev-qt/linguist-tools:5 )
+"
+RDEPEND="
+       dev-db/lmdb:=
+       >=dev-libs/glib-2.58:2
+       dev-libs/libxml2:2
+       dev-libs/libyaml
+       dev-libs/snowball-stemmer
+       >=net-libs/libsoup-2.56:2.4
+       introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+       qt5? ( dev-qt/qtcore:5 )
+"
+DEPEND="${RDEPEND}
+       test? ( qt5? ( dev-qt/qttest:5 ) )
+"
+
+src_prepare() {
+       default
+       sed -e "/^as_doc_target_dir/s/appstream/${PF}/" -i docs/meson.build || die
+       if ! use test; then
+               sed -e "/^subdir.*tests/s/^/#DONT /" -i {,qt/}meson.build || die # bug 675944
+       fi
+}
+
+src_configure() {
+       xdg_environment_reset
+
+       local emesonargs=(
+               -Dapidocs=false
+               -Ddocs=false
+               -Dmaintainer=false
+               -Dstemming=true
+               -Dvapi=false
+               -Dapt-support=$(usex apt true false)
+               -Dinstall-docs=$(usex doc true false)
+               -Dgir=$(usex introspection true false)
+               -Dqt=$(usex qt5 true false)
+       )
+
+       meson_src_configure
+}