dev-libs/libite: bump version to 2.1.2
authorOz Tiram <oz.tiram@gmail.com>
Sun, 23 Feb 2020 08:52:30 +0000 (09:52 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 27 Feb 2020 13:54:41 +0000 (15:54 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.16
Signed-off-by: Oz Tiram <oz.tiram@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/libite/Manifest
dev-libs/libite/libite-2.1.2.ebuild [new file with mode: 0644]

index 1c523fdd246128830a50fe7a655f0a5a1c7e5e9a..be57f52670332c18ee2b53edceb4b5abd188b136 100644 (file)
@@ -1,2 +1,3 @@
 DIST libite-2.0.0.tar.xz 259960 BLAKE2B 4c5393daaf2ca6eb830fc5f11b1d38e9c1e2374c5f5d87bb973c7e54b9f81480d4a270a4551689806620cd5a84671d1055d409d6dd090acb64bf7fc454d1c283 SHA512 18516f19d36d81169116562b4b27d76240715424cdde9b87eae831f35adb17d70fb01e2eae5e7e9ce99e2c88344c2c15d2b7d11f4ea2e9ae0deb25ee5ee4c563
 DIST libite-2.1.0.tar.xz 265712 BLAKE2B c8a0f2a55bc6e0ae2ad774be67501d2d8ec31927cc107b1b38de409ce78334b9a516727722aa57d615b234edf1057967b2375a96dd947637e987d2583e2efc2a SHA512 dd6b48ed6dc646ce2d17e647179173bf5d3b478db38f05c2133119ce81da9778be8bb277db9beb0e28aeff7f81cb3fc361d3737de31623f6661141efa63d64d3
+DIST libite-2.1.2.tar.xz 265524 BLAKE2B 6e89fda5267e9beb8b057d195f1ed7503fc898146e64da2735510ee9fe703a9ee7d1f21e67a7820cd9ae413ee77b66c050d6534553b5a6ce113c113a7fd58f06 SHA512 92c3830344d7816cbcc2a697bf55b53557d4df7bab4d3db5aa6319379c82a14cf021d18402eae724c5b9126ec06df9728ee6ded9599117cc7f3fa7a0b2f997cc
diff --git a/dev-libs/libite/libite-2.1.2.ebuild b/dev-libs/libite/libite-2.1.2.ebuild
new file mode 100644 (file)
index 0000000..f0baf55
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libite"
+SRC_URI="https://github.com/troglobit/libite/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_configure() {
+       econf --enable-static=$(usex static-libs)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+       rm "${D}/usr/share/doc/${PF}/LICENSE" || die
+}