Migrated to generation 2.
authorKrzysztof Pawlik <nelchael@gentoo.org>
Tue, 9 Jan 2007 17:17:04 +0000 (17:17 +0000)
committerKrzysztof Pawlik <nelchael@gentoo.org>
Tue, 9 Jan 2007 17:17:04 +0000 (17:17 +0000)
Package-Manager: portage-2.1.2_rc4-r7

dev-java/classworlds/ChangeLog
dev-java/classworlds/classworlds-1.0-r3.ebuild [new file with mode: 0644]
dev-java/classworlds/files/digest-classworlds-1.0-r3 [new file with mode: 0644]

index b20e9d712fee057a28d13afbba8c044a0d1da987..3d67fdc3afc99c6c0fe1070c6fed21e4b0c49a64 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-java/classworlds
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/classworlds/ChangeLog,v 1.15 2006/11/30 15:25:03 caster Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/classworlds/ChangeLog,v 1.16 2007/01/09 17:17:04 nelchael Exp $
+
+*classworlds-1.0-r3 (09 Jan 2007)
+
+  09 Jan 2007; Krzysiek Pawlik <nelchael@gentoo.org>
+  -classworlds-1.0-r2.ebuild, +classworlds-1.0-r3.ebuild:
+  Migrated to generation 2.
 
   30 Nov 2006; Vlastimil Babka <caster@gentoo.org>
   classworlds-1.0-r2.ebuild:
diff --git a/dev-java/classworlds/classworlds-1.0-r3.ebuild b/dev-java/classworlds/classworlds-1.0-r3.ebuild
new file mode 100644 (file)
index 0000000..9c9b41b
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/classworlds/classworlds-1.0-r3.ebuild,v 1.1 2007/01/09 17:17:04 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Advanced classloader framework"
+HOMEPAGE="http://dist.codehaus.org/classworlds/distributions/classworlds-1.0-src.tar.gz"
+SRC_URI="http://dist.codehaus.org/classworlds/distributions/${P}-src.tar.gz"
+LICENSE="codehaus-classworlds"
+SLOT="1"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc"
+
+RDEPEND=">=virtual/jre-1.4
+       >=dev-java/xerces-2.7"
+DEPEND=">=virtual/jdk-1.4
+       ${RDEPEND}
+       >=dev-java/ant-core-1.6"
+
+src_unpack() {
+       unpack ${A}
+       cp ${FILESDIR}/build-${PV}.xml ${S}/build.xml
+       mkdir -p ${S}/target/lib
+
+       cd ${S}/target/lib
+
+       # karltk: remove the fake versioning here.
+       java-pkg_jar-from xerces-2
+}
+
+src_compile() {
+       local antflags="jar"
+       use doc && antflags="${antflags} javadoc"
+       eant ${antflags}
+}
+
+src_install() {
+       java-pkg_newjar target/${P}.jar ${PN}.jar
+       use doc && java-pkg_dohtml -r dist/docs/api
+}
diff --git a/dev-java/classworlds/files/digest-classworlds-1.0-r3 b/dev-java/classworlds/files/digest-classworlds-1.0-r3
new file mode 100644 (file)
index 0000000..f7ee70b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 739f9eb7f9677a1a5dd9ec1c4c7f66ae classworlds-1.0-src.tar.gz 32611
+RMD160 d011823b30d9b1387ad86c52019409454d0a80c6 classworlds-1.0-src.tar.gz 32611
+SHA256 0b96924b672fc656a84bbbd50f9988c8dfc7b8bda92721c70ab83fe71d9ce061 classworlds-1.0-src.tar.gz 32611