sci-libs/ceres-solver: Drop 1.11.0
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 12:34:42 +0000 (13:34 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 19 Mar 2020 13:23:27 +0000 (14:23 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-libs/ceres-solver/Manifest
sci-libs/ceres-solver/ceres-solver-1.11.0.ebuild [deleted file]

index 6a7c6cb6b192ea8d0df04319414b1996621273e3..9eea55fad9faac0b8301240e97c0080f11b20ee6 100644 (file)
@@ -1,2 +1 @@
-DIST ceres-solver-1.11.0.tar.gz 3944965 BLAKE2B cafae018abde9b8085f7e8841a6a720ef52cd40178a43c3050b6b20465bc9675cc326a6bc405572a235758c5f2f99e936375f711bf5c4b121acfe0c0641713c6 SHA512 4941538e6ec31e2ee56a24446748dc5d6dd02ba9c151e4320a2db943fd1a377455b0ee23d56780e1f05322b30e25057145c540fde901d7fd2244ec630a73527c
 DIST ceres-solver-1.12.0.tar.gz 5008861 BLAKE2B 52b3954dde96386bd031543ab9d7370368f58f76f1dec9d24ef10803da787cc96f40a1c775626fde832b70ebd94cf4274c70a8fb4bd7e1bcf040e119cbec09f8 SHA512 485eece0471cf05d31b5dd7e133e23115a334a4ed557a3c1bd0b715a063f840738af8f507e935522a0dae90ce6851984c0002a25e9b445b90889792f68a05571
diff --git a/sci-libs/ceres-solver/ceres-solver-1.11.0.ebuild b/sci-libs/ceres-solver/ceres-solver-1.11.0.ebuild
deleted file mode 100644 (file)
index d8f758d..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-multilib eutils python-any-r1 toolchain-funcs
-
-DESCRIPTION="Nonlinear least-squares minimizer"
-HOMEPAGE="http://ceres-solver.org/"
-SRC_URI="http://ceres-solver.org/${P}.tar.gz"
-
-LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 ) cxsparse? ( BSD )"
-SLOT="0/1"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cxsparse c++11 doc examples gflags lapack openmp +schur sparse test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
-
-RDEPEND="
-       dev-cpp/glog[gflags?,${MULTILIB_USEDEP}]
-       cxsparse? ( sci-libs/cxsparse:0= )
-       lapack? ( virtual/lapack )
-       sparse? (
-               sci-libs/amd:0=
-               sci-libs/camd:0=
-               sci-libs/ccolamd:0=
-               sci-libs/cholmod:0=
-               sci-libs/colamd:0=
-               sci-libs/spqr:0=
-       )"
-
-DEPEND="${RDEPEND}
-       dev-cpp/eigen:3
-       doc? ( dev-python/sphinx dev-python/sphinx_rtd_theme )
-       lapack? ( virtual/pkgconfig )
-       ${PYTHON_DEPS}"
-
-pkg_pretend() {
-       if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
-               if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
-                       ewarn "OpenMP is not available in your current selected gcc"
-                       die "need openmp capable gcc"
-               fi
-       fi
-}
-
-pkg_setup() {
-       use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
-       # search paths work for prefix
-       sed -e "s:/usr:${EPREFIX}/usr:g" \
-               -i cmake/*.cmake || die
-
-       # remove Werror
-       sed -e 's/-Werror=(all|extra)//g' \
-               -i CMakeLists.txt || die
-
-       # respect gentoo doc install directory
-       sed -e "s:share/doc/ceres:share/doc/${PF}:" \
-               -i docs/source/CMakeLists.txt || die
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       # CUSTOM_BLAS=OFF EIGENSPARSE=OFF MINIGLOG=OFF CXX11=OFF
-       local mycmakeargs=(
-               -DBUILD_SHARED_LIBS=ON
-               -DBUILD_EXAMPLES=OFF
-               -DENABLE_TESTING="$(usex test)"
-               -DCXX11="$(usex c++11)"
-               -DBUILD_DOCUMENTATION="$(usex doc)"
-               -DGFLAGS="$(usex gflags)"
-               -DLAPACK="$(usex lapack)"
-               -DOPENMP="$(usex openmp)"
-               -DSCHUR_SPECIALIZATIONS="$(usex schur)"
-               -DCXSPARSE="$(usex cxsparse)"
-               -DSUITESPARSE="$(usex sparse)"
-       )
-       use sparse || use cxsparse || mycmakeargs+=( -DEIGENSPARSE=ON )
-       cmake-multilib_src_configure
-}
-
-src_install() {
-       cmake-multilib_src_install
-       dodoc README.md VERSION
-
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               docompress -x /usr/share/doc/${PF}/examples
-               doins -r examples data
-       fi
-}